Anybody help! I want to solve some issues with sleeping.

Joined
Sep 16, 2018
macOS
10.13.6
Mobo
Asus P8H61-M LX
CPU
Intel Core i5 2500K
GPU
Intel HD Graphics 3000 + NVIDIA GeForce GTX 750 Ti
#1
1, my hackintosh machine can sleep but just for a few seconds and the fans and HDD or some devices will start working.
2, i have tried many ways to solve this issue, such as install DSDT.aml and Patch USB limit.
Do you have any method to solve this issue?
I really want some useful advice from you!
Thanks for replying.

Cheers,
Brian
 
Joined
Jul 3, 2018
Mobo
ASUS Z370-E Gaming ROG Strix
CPU
Intel i7 7800k 3.7Ghz
GPU
Asus Strix gaming Radeon RX 580
#2
Make sure “wake from pcie “ is off in your bios
 
Joined
Sep 16, 2018
macOS
10.13.6
Mobo
Asus P8H61-M LX
CPU
Intel Core i5 2500K
GPU
Intel HD Graphics 3000 + NVIDIA GeForce GTX 750 Ti
#3
It's disabled in my bios settings.
 
Joined
Jun 4, 2018
macOS
Mobo
Gigabyte Z370N WIFI (BCM94352Z / 04X6020)
CPU
Intel® Core™ i5-8400
GPU
Sapphire Pulse RX570 ITX
#4
I had the same problem and did a few tweaks in Clover and now it seems to be ironed out:

It must be due to a conflict in your config. Mojave seems to require proper config of iGPU irrespectively of a dedicated GPU being present.

I had to copy back Whatevergreen.kext in the kext > other folder (SD card reader was not functioning w/o it)
I removed NoVPAJpeg.kext (optional)
Set IGPU in BIOS to Auto (if you are on GPU)
Configured HD630 in Clover properly / see guide on Hackintosher
Note that I am on custom SSDT and not using USBinjectAll.kext, XHCI-X00-series-injector and USB patch however the USBinject does not seem to effect sleep.

TBH I am not sure which of the above steps eliminated the problem and oddly if an active USB connections (SD card, external drive) are present I still receive the 'Disk Not Ejected Properly' messages on wake.
Tinker about iGPU/GPU settings!
 
Joined
Jul 3, 2018
Mobo
ASUS Z370-E Gaming ROG Strix
CPU
Intel i7 7800k 3.7Ghz
GPU
Asus Strix gaming Radeon RX 580
#5
ill have to give that a go. anything is better than having to reboot every time the computer sleeps