ASUS Z370-I ITX Build Need PLIST

drw1710

New member
Joined
May 19, 2020
macOS
10.15.5
Mobo
Asus Z370
CPU
I5 9400
GPU
AMD RX 550
#1
I am new to Hackintoshing and need some assistance with this build. M first build went pretty well but this one makes me want to throw it out the upstairs window.

No matter what guide I follow I can't get this one to work, I did have one success but the display was magenta and the more I worked to correct it the worse things got. Now I can't get anything to work.

I have started over and over and over, I can't get it to boot, it hangs at the apple logo screen. verbose does not work usually but other times it may.

It seems like a config issue to me but I am not savvy enough to know where the issue is.
Here is the build
Asus Z370-i gaming ITX
Core I5 9400
16 gb Gskill ram
AMD RX 550
 

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.15.5
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
Powercolor RX 580 8GB
#2
Try this CLOVER folder. Use it in place of your current CLOVER folder on a Mojave 10.14.6 or any Catalina USB installer.

About the only thing I am not sure about is your AMD RX 550 dGPU. It may require some additional patching to get it working.
 

Attachments

drw1710

New member
Joined
May 19, 2020
macOS
10.15.5
Mobo
Asus Z370
CPU
I5 9400
GPU
AMD RX 550
#3
Thank you for the help, sadly it hung.
I am attaching to screen photos one is with a graphics card one without
 

Attachments

drw1710

New member
Joined
May 19, 2020
macOS
10.15.5
Mobo
Asus Z370
CPU
I5 9400
GPU
AMD RX 550
#4
if it helps I don't have to have a video card with it.
 

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.15.5
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
Powercolor RX 580 8GB
#5
Provide a copy of your APCI tables, the error is related to a specific issue that can be fixed with an SSDTxEC.aml. But it needs to be correct for your specific syste.

The ACPI tables can be obtained by pressing the F4 key while on the clover boot screen. The tables will be saved in the background with no indication anything is happenin. They will be saved to the /Clover/ACPI/origin folder on your usb installaction drive. Compress the folder and attach it here.
 

drw1710

New member
Joined
May 19, 2020
macOS
10.15.5
Mobo
Asus Z370
CPU
I5 9400
GPU
AMD RX 550
#6
Here is the compressed file you asked for, thank you so much for y our assistance!
 

Attachments

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.15.5
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
Powercolor RX 580 8GB
#7
Try the attached CLOVER folder. I have edited the config.plist, added three different SSDT's, which should fix the AE_NOT_FOUND kernel panic.

Use the whole folder not just parts of it.

Let me know if it helps.
 

Attachments

drw1710

New member
Joined
May 19, 2020
macOS
10.15.5
Mobo
Asus Z370
CPU
I5 9400
GPU
AMD RX 550
#8
I decided to start fresh with my installer USB incase there was some error with it. once I had it created, I removed the clover folder and inserted yours. here is a copy of the origin folder with he results of the failed boot.
 

Attachments

drw1710

New member
Joined
May 19, 2020
macOS
10.15.5
Mobo
Asus Z370
CPU
I5 9400
GPU
AMD RX 550
#9
I made a few changes and now have finally gotten this thing to boot and load Catalina, I had to add a video card (Nvidia gt710) not much of a card but its working. I made a couple of changes in the plist config after I installed the card and it worked. The only issue I have is HDMI sound. I think I need that HDMI audio kext. I will keep plugging away on this thing. Could not have done it without you, Thank. you so very much.
 

drw1710

New member
Joined
May 19, 2020
macOS
10.15.5
Mobo
Asus Z370
CPU
I5 9400
GPU
AMD RX 550
#10
here is a copy of the latest plist.
 

Attachments

drw1710

New member
Joined
May 19, 2020
macOS
10.15.5
Mobo
Asus Z370
CPU
I5 9400
GPU
AMD RX 550
#11
now the only remaining issues are HDMI audio and the usb3
 

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.15.5
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
Powercolor RX 580 8GB
#12

drw1710

New member
Joined
May 19, 2020
macOS
10.15.5
Mobo
Asus Z370
CPU
I5 9400
GPU
AMD RX 550
#13
I just noticed something odd regarding the USB3, a wired keyboard and mouse work fine but not USB storage devices
 

Attachments

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.15.5
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
Powercolor RX 580 8GB
#14
The wired USB keyboard and mouse are USB2, the Storage device is probably USB3. Without a custom SSDT or USBPorts.kext your first 15 USB ports in your system will be activated, this usually means all 14 USB2 ports and 1 USB3 port are activated.

Each USB3 port has two virtual ports, a USB2 side and a USB3 side. The USB2 sides of the USB3 physical ports will work but the USB3 sides won't work.

I will have a look at the CLOVER folder, I am assuming this is the CLOVER folder you are currently using with your Asus Z370 ITX build.
 

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.15.5
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
Powercolor RX 580 8GB
#15
Where is the rest of the CLOVER folder? You have stripped out the guts of the folder, so it's not much use if I'm honest.

Provide a copy of the Whole CLOVER folder, as I specifically need to see the CLOVER/ACPI/origin, CLOVER/drivers/UEFI and CLOVER/kexts/Other folders, plus the other sub-folder contents to make sure nothing untoward has been included.

To populate the /CLOVER/ACPI/origin folder press the F4 key while on the Clover boot screen, this will extract the ACPI tables and save them to your /CLOVER/ACPI/origin folder.
 

drw1710

New member
Joined
May 19, 2020
macOS
10.15.5
Mobo
Asus Z370
CPU
I5 9400
GPU
AMD RX 550
#16
Ok this one is complete, everything works and it as best I can tell stable. HDMI audio, USB 3.0/3.1 ports work great, wifi, and Bluetooth work.. it is not an IGP but I can sort that out later.

I used open core with this one and it worked straight out of the box with no issues.

Thank you to everyone who helped me with this pain in the butt lol.
 
Last edited:

Latest posts