Battery status in Mojave on HP ProBook 450 G6

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.15.5
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
Powercolor RX 580 8GB
#21
Not totally surprised that happened.

Questions:
  1. Did you obtain all the SSDT's in your /CLOVER/ACPI/patched folder from the Aspire Swift guide you linked from Tonymacx86?
  2. Did you obtain the SSDT's from one of Rehabman's Probook guides?
  3. Did you obtain the SSDT's from a guide for your Probook 450 G6?
  4. Did you obtain the SSDT's from somewhere else?
 

Dev.Anas

New member
Joined
Nov 5, 2019
macOS
10.14.6
Mobo
A10
CPU
i7855u
GPU
Intel® HD Graphics 620
#22
Not totally surprised that happened.

Questions:
  1. Did you obtain all the SSDT's in your /CLOVER/ACPI/patched folder from the Aspire Swift guide you linked from Tonymacx86?
  2. Did you obtain the SSDT's from one of Rehabman's Probook guides?
  3. Did you obtain the SSDT's from a guide for your Probook 450 G6?
  4. Did you obtain the SSDT's from somewhere else?
DSDT is generated by clover , then i apply
from the left pane, apply "[GPIO] GPIO Controller Enable "SKL+" and "[Windows] Windows 10 Patch" in the "_VoodooI2C-Patches" section.

also Pure DSDT is in origin folder which generated by clover .

only i obtain all the SSDT's from the Aspire Swift guide you linked from Tonymacx86 without DSDT . and its work fine with me without battery and when i apply battery patch that i past it in previous post , also battery status work ( but whit some issue that listed in post ) .
 
Last edited:

Dev.Anas

New member
Joined
Nov 5, 2019
macOS
10.14.6
Mobo
A10
CPU
i7855u
GPU
Intel® HD Graphics 620
#23
Not totally surprised that happened.

Questions:
  1. Did you obtain all the SSDT's in your /CLOVER/ACPI/patched folder from the Aspire Swift guide you linked from Tonymacx86?
  2. Did you obtain the SSDT's from one of Rehabman's Probook guides?
  3. Did you obtain the SSDT's from a guide for your Probook 450 G6?
  4. Did you obtain the SSDT's from somewhere else?
i think you attach the wrong file , because it raise some error . please review the attach file .
 

Attachments

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.15.5
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
Powercolor RX 580 8GB
#24
No I didn't attache the wrong file. That was the file I compiled without errors after applying the revised Probook battery patch and the AC adapter patch.

This is the result window when I compile the DSDT-Bat+AC.dsl on my system:

Screenshot 2019-11-15 at 20.53.41.png No errors when compiled.

I have attached a disassembled and patched copy of the DSDT, so you can compile it on your system.
 

Attachments

Dev.Anas

New member
Joined
Nov 5, 2019
macOS
10.14.6
Mobo
A10
CPU
i7855u
GPU
Intel® HD Graphics 620
#25
Again Thanks For Help me , now my laptop work fine ..

what i do :

1- Follow guide From Here
https://www.tonymacx86.com/threads/guide-acer-swift-5-sf514-53t-whiskey-lake-macos10-14-5.277618/
2- apply DSDT patch
from the left pane, apply "[GPIO] GPIO Controller Enable "SKL+" and "[Windows] Windows 10 Patch" in the "_VoodooI2C-Patches" section.
3- apply bat patch https://www.tonymacx86.com/threads/...g-battery-status.116102/page-509#post-2021126
4- bat work fine and when reach to 75% it convert to red and show warning , after i restart laptop work agin fine ( its not big issue red indictor ) ..
5- Copy SSDT-EC.aml to EFI/CLOVER/ACPI/Patched .
 

Attachments

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.15.5
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
Powercolor RX 580 8GB
#26
Good to hear and for you to share your findings.
 

_Zaizen_

New member
Joined
Jan 24, 2020
macOS
10.14.6
#27
Hello everyone.

System:

HP Probook 450 G6
i7 8550U
16Gb RAM
256 GB SSD (WD)
No Wireless till now. (maybe in the next few weeks)

96% works fine.

Problems:

1. The Trackpad not works .
2. I can't see my battery stats .

Here's my config plist attached.

Do you guys have any lead ? Thanks !
Hi, I'm tyryng to create Hackintosh on the same laptop with same specs but I can't get VirtualSMC to work. every time I put it instead of FaceSMC at the boot I gat AppleACPICPU timeout so it never boots up. Any suggestion? I have vtd/vtx enabled. Tried disabling them but no luck.