Can't get Catalina to install Razer Blade Stealth 2019

itpoet

New member
Joined
Jun 3, 2020
#1
I am able to get to the part where I format the disk. I format the entire 1tb nvme ssd as apfs.
The specs are a core i7, and the mx150. After looking on the forum I see that it's not listed, but there is an article I read that they were able to do it with the same laptop as mine. I'm able to get through the install process to the reboot. Then after reboot I make sure it is booting from the new partition for clover and then.... it takes me right back to the original setup menu, I click on continue, agree, and then select install again. Same thing. So, I don't know if there are any customizations that I need for my setup. Any help would be greatly appreciated.
 

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.15.7
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
Powercolor RX 580 8GB
#2
You need to keep booting from the USB installer.

If an icon is available on the Clover boot screen to select 'install macOS from [name of drive]...' then select it until it no longer shows on the boot screen.

Then you should be left with the 'boot macOS from [name of drive]' icon, which you would need to select to complete the installation.
 

itpoet

New member
Joined
Jun 3, 2020
#3
You need to keep booting from the USB installer.

If an icon is available on the Clover boot screen to select 'install macOS from [name of drive]...' then select it until it no longer shows on the boot screen.

Then you should be left with the 'boot macOS from [name of drive]' icon, which you would need to select to complete the installation.
it doesn’t appear to have that option. i can boot from usb, or boot recovery from recovery.
 

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.15.7
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
Powercolor RX 580 8GB
#4
Post a screenshot here showing your Clover Boot Screen. You may need to take a few so each icon's name is shown so they can be clearly identified. Just use the arrow keys to highlight each icon and then take a screenshot showing each icon's name.

You need to press F10 key to take a screenshot while on the clover boot screen, the image(s) should be saved to your USB Drive in the /EFI/CLOVER/misc folder.

What Volumes if any have you listed to be hidden on the boot screen? These would be listed in the GUI section of the config.plist you are using.

Post a copy of your CLOVER folder, so we can see what you are using to boot the system.

You need to provide details of your system in the member profile, so it is visible under your name when you submit a post. Otherwise we won't know what system you are using/hacking. Keeping the version of macOS you are installing/running up to date is really helpful.
 

itpoet

New member
Joined
Jun 3, 2020
#5
Here they are. Could be something wrong with boot flags, maybe? I'm running i7 whiskey lake. 16gb ram, samsung 1tb 970 evo. It's a blade stealth so it's a razer mb. It's a late 2019 model with the mx150.
Edit: the steps I take to flash the USB: i transfer the niresh catalina onto the usb with transmac. It boots everything properly, it just fails to install fully.
 

Attachments

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.15.7
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
Powercolor RX 580 8GB
#6
First:
There version of Clover you are using on the USB is old, too old to run macOS Catalina without issues. I would recommend you download and install a more recent version of Clover to the USB.

Here is a link to the GitHub page for Clover releases,- https://github.com/CloverHackyColor/CloverBootloader/releases

Your USB is using Clover_r5045 the most recent version is Clover_r5118, which has been updated a few times recently to deal with issues introduced by macOS Catalina.

As you are using Hackintosh Zone your CLOVER folder will be shite. I will have a look to see if I can amend it to work with your system.

A link to the specification page for your system would help, so I know which components are contained/included in the motherboard.
 

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.15.7
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
Powercolor RX 580 8GB
#7