Clover 4509

Joined
Feb 21, 2018
macOS
10.14.6
Mobo
Z370 Aorus Gaming 7
CPU
Intel Core i7 8700K
GPU
Aorus RX570 4G
#1
Has anyone updated Clover to 4509? On my system I use Clover from the EFI partition of an OS X 10.13 NVMe drive (APFS) and otherwise have one Windows 8.1 NVMe drive and one Fusion Drive with 10.13 on HFS+. With Clover 4497 I had entries for all three OSes. With 4509, I can only see the OSes on the NVMe drives. If I press F3 to view hidden entries from 4509, there are no entries visible for the Fusion Drive OS X. I can see the Fusion Drive in Finder however and access all the files ok. I created a workaround by installing Clover 4497 in the EFI partition of the Fusion Drive (on the SSD EFI partition), so I can boot up 4497 from the BIOS boot menu or start up 4497 from within the hidden entries in 4509. But I haven't figured out how to make OS X from Fusion Drive appear in 4509. Any ideas please? Other than simply reverted back to 4497 in the main EFI partition? Cheers.

Out of interest, do you generally update Clover to the latest version on a regularly basis or not bother? I install the updates but it's difficult from a user perspective to see what has changed and what the improvements are. I can see that you need to update Clover when you upgrade OS X to the next version but otherwise is there any real benefit? Generally 50% of the time it causes problems with sound not functioning (needing to adjust the inject values) or other weirdness. I figure even if the latest Clover has an issue or two on my system, it will be the same with subsequent versions so I may as well update now and fix it. But I'm wondering if this is sensible lol
 
Last edited:

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.15.5
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
Powercolor RX 580 8GB
#2
Have you installed HFSPlus-64.efi to EFI/Clover/drivers64UEFI folder? Without this file you won't be able to see your HFS drives. The latest version has stopped installing VBoxHfs-64.efi or any other HFS file, you need to manually select a HFS.efi file as part of the new clover installation (customisation).

Yes, I tend to update Clover on a regular basis, not every version but around once a month I check for updates in Clover Configurator.

If your config.plist is set correctly you should not notice any issues when you update Clover, it just requires a bit of house cleaning to remove some empty folders and check that you have not missed installing one of the .efi files you need in drivers64UEFI.
 
Last edited:
Likes: dkjackson
Joined
Feb 21, 2018
macOS
10.14.6
Mobo
Z370 Aorus Gaming 7
CPU
Intel Core i7 8700K
GPU
Aorus RX570 4G
#3
Thanks very much for your help Edhawk. It worked!

I probably have a few unnecessary kexts and drivers. I've deleted some but try to be cautious these days in terms of installation and deletion of new drivers after getting carried away with Multibeast when I first installed my computer and ended up wiping it and starting again.
 
Last edited:
Joined
Mar 15, 2018
macOS
10.15.5
Mobo
ASUS ROG Maximus X Hero WiFi
CPU
I7-8700K
GPU
Sapphire NITRO+ RX580 8GB
#4
@Edhawk Thanks for this information. I had the same problem with Clover 4509 not sseing any driver to boot to. Thank god I'm consistent with backups so I could recover, find this answer, and get Clover updated.
 
Joined
Feb 21, 2018
macOS
10.14.6
Mobo
Z370 Aorus Gaming 7
CPU
Intel Core i7 8700K
GPU
Aorus RX570 4G
#5
I note in Clover 4522 the VBox HFS+ driver is installed automatically again, however, strangely whilst it works on my system, the bottom half of the Clover screen is black and I can't read the menus properly so I rolled back to 4509 again.