Faultless GA-Z68XP Install

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.14.6
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
2 x Powercolor RX 580 8GB
#21
Clover would be the best bootloader to use in the long run, in my opinion.

Tonymacx86's Unibeast USB installation app uses a modified version of Clover.

You can use Tonymacx86's post install tool Multibeast, with any bootloader, as long as you don't over ride the boot files with another bootloader, i.e. boot with Enoch and then run Multibeast in Clover legacy mode.

There is nothing wrong with using these tools, but they do tend to slow down the learning curve or rather dumb down the hackintosh learning. As they don't help you understand what it is they are doing, people just press a few buttons and input their password and hey presto! their hackintosh is working and they have no idea how.

My preferred option is to use Apple's CreateInstallMedia command in Terminal to make the bootable USB drive, use the latest Clover version from Source Forge for the bootloader, use Rehabman's kexts, fixes etc. and Vit9696's Lilu kext and the plugins for Lilu. But that is just my personal choice, this is one way and it does not fit everybody. What I would state though is that you would be better off staying well clear of any Distro's.

Let me know if you have any problems installing macOS when your new SSD arrives.
 
Joined
Jun 26, 2018
macOS
Mobo
GA-Z68XP-UD5
CPU
i7-2600K
GPU
2x Radeon 6800 1GB
#22
Got a new SSD, now i cannot boot in Bios with F12. Seems like there is no keyboard connected, but it is. Tried also a second one. No Success. Any Idea what is wrong??
 
Joined
Jun 26, 2018
macOS
Mobo
GA-Z68XP-UD5
CPU
i7-2600K
GPU
2x Radeon 6800 1GB
#23
Do i need to connect direct to internal GUI or can i leave it on the ATI 6850.
Also i have 4 HDD connected.
 

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.14.6
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
2 x Powercolor RX 580 8GB
#25
When you are undertaking a clean install I would recommend you only have the proposed boot disk attached, less chance of things going wrong. You can attach any other disks once macOS is up and running.

If your two Radeon HD 6800 graphics cards are identified correctly and work out of the box under OSX/macOS then have them both installed while you run the installation. Otherwise you may run in to graphics issues/kernel panics during the installation.

You need to press Delete to bring up Bios Setup, press F12 for one time Boot drive selection on Gigabyte motherboards, although you can get to the bios via the F12 selection.

Try your keyboard in another USB port, see if that helps. All of the USB ports should be working at bios boot stage, unless you have expressly disabled them in the bios previously.

If your new SSD is formatted HFS, make sure you have HFSPlus-64.efi in your EFI/Clover/drivers64UEFI folder for UEFI boot or EFI/Clover/drivers64 folder for legacy boot, as well as there correct apfs.efi for the version of macOS you are installing.
 
Joined
Jun 26, 2018
macOS
Mobo
GA-Z68XP-UD5
CPU
i7-2600K
GPU
2x Radeon 6800 1GB
#26
First install got screwed up. Booted automatically Clover from USB, installed Sierra, went OK till i installed Enoch and used the setting you posted and after Reboot........KP
 

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.14.6
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
2 x Powercolor RX 580 8GB
#27
If you have a working Clover config.plist why switch to Enoch? Just install Clover on the SSD and use the kexts, drivers and config.plist from the USB!
 
Joined
Jun 26, 2018
macOS
Mobo
GA-Z68XP-UD5
CPU
i7-2600K
GPU
2x Radeon 6800 1GB
#31
Installed Security Updates and Screen went black and Ball is spinning?
Had another issue: I opened a second Finder Window and Hack went off and reboot. When it do that then Bios is changed in IDE mode. WHAT CAN THAT BE???
 
Joined
Jun 26, 2018
macOS
Mobo
GA-Z68XP-UD5
CPU
i7-2600K
GPU
2x Radeon 6800 1GB
#32
Since i installed Updates from App Store. Booting till Screen comes up for entering Password, then dark and he shuts off??????????????????
 

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.14.6
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
2 x Powercolor RX 580 8GB
#33
Don't install any updates till you have your hack up and running/booting without any issues.

I would suggest you do a clean install, again. Then get clover installed and configured so you can boot without any issues. Make sure you have all the necessary kexts that you used in your USB boot drive in the correct locations, whether that be the new EFI/Clover/Kexts/Other folder on your SSD or /Library/Extensions. You need to have the UEFI drivers installed or copied from your USB boot drive, plus the Clover Theme specified in your config.plist in the themes folder.

Once your Hack is running smoothly then install the Security updates, they should proceed without any issues once your hack is stable.
 
Joined
Jun 26, 2018
macOS
Mobo
GA-Z68XP-UD5
CPU
i7-2600K
GPU
2x Radeon 6800 1GB
#34
Problem also is, that my Bios is changing from AHCI Mode to IDE and then i have booting problems. When i start the Hack then i have EFI Bios Logo up and no more the Post Screen. I used the Kexts you provided. I try again to install with the Kexts. How I install UEFI Legacy in Clover. Don't see it when Clover is up?
 

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.14.6
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
2 x Powercolor RX 580 8GB
#35
You SATA ports need to be set as AHCI for macOS to recognise them correctly. If it changes to IDE, you need to change it back to AHCI.

I am not sure what you mean by 'UEFI Legacy in clover' it is either UEFI or Legacy boot mode that is chosen when installing Clover.

Your motherboard is a Z68 (6 series) Intel board, so you should install Clover for legacy booting not UEFI. I have read about people having problems with the 'UEFI bios update' that was issued for some older 6 Series motherboards.

If you have updated your bios to this UEFI bios and you plan to stick with it, you will need to change the installation of Clover on your USB installation drive. You will need to select 'Booting for UEFI only' which should also automatically select 'install Clover in the ESP' and place the Clover folder on the EFI partition of the installation drive.
 
Joined
Jun 26, 2018
macOS
Mobo
GA-Z68XP-UD5
CPU
i7-2600K
GPU
2x Radeon 6800 1GB
#36
When Hack crashed it set automatic the SATA from AHCI to IDE. I will try again.
 
Joined
Jun 26, 2018
macOS
Mobo
GA-Z68XP-UD5
CPU
i7-2600K
GPU
2x Radeon 6800 1GB
#37
Hack is booting only from USB. If boot from SSD it stucked at "Loading Operation System"
Clover Bootloader don't load. Have all Kext in the right EFI Folders and also in Extensions.
Installation went fine, installed Clover on SSD with all the Settings as shown.
Still changing Bios. Had overclock to 4.2ghz. Auto changing to 3.5ghz and IDE.
Did the Clover installation as shown in Pics.
 
Joined
Jun 26, 2018
macOS
Mobo
GA-Z68XP-UD5
CPU
i7-2600K
GPU
2x Radeon 6800 1GB
#39
Installed Sierra again. As soon i tried to copy Kext from USB drive to SSD...Puff Off and reboot.
It's like a loop. You click on a file and Off--reboot.
 
Joined
Jun 26, 2018
macOS
Mobo
GA-Z68XP-UD5
CPU
i7-2600K
GPU
2x Radeon 6800 1GB
#40
Are you here in the States??? Maybe we can setup teamviewer so you can see what happens om my hack.