GC-Alpine Ridge issues, Titan Ridge? [Thunderbolt]

Joined
Jan 24, 2018
macOS
10.14.2
Mobo
Gigabyte Z370 Aorus Gaming 7
CPU
Intel i7-8700K
GPU
Asus Radeon RX 580
#1
Hey!

I've had a Gigabyte GC-Alpine Ridge Thunderbolt card for almost a year. Once I got it going it's been working great with my UA Apollo Twin mkII Thunderbolt Audio Interface.

Now I've gotten myself a Sonnet Solo 10G 10GbE adapter. Turns out Thunderbolt port 2 isn't working... by unseating the PCI card and unconnecting/reconnecting the THB_C header cable I got them both to work! Until next day when port 2 didn't work again... And nothing I've done can get it to work again... It's also not working in Windows, so doesn't seem to be a Hackintosh issue.

Since firmware F11 my motherboard (Z370 Auros Gaming 7) it's supposed to support the GC-Titan Ridge card. Which potentially might be a better cards (some reports of hot-swapping working on hackintosh!), I'm thinking of just buying one of those.

Anyone have experience with the Titan Ridge?
 
Joined
Jan 24, 2018
macOS
10.14.2
Mobo
Gigabyte Z370 Aorus Gaming 7
CPU
Intel i7-8700K
GPU
Asus Radeon RX 580
#2
Ok, I ordered a GC-Titan Ridge, will report back once I have it!
 
Joined
Jan 24, 2018
macOS
10.14.2
Mobo
Gigabyte Z370 Aorus Gaming 7
CPU
Intel i7-8700K
GPU
Asus Radeon RX 580
#3
Recieved my Titan Ridge... and it's working!!!

Got the Sonnet Solo 10G and Apollo Twin mkII both working at the same time!

One time when I restarted, the Mac didn't find the Solo 10G... so time will tell how reliable it will be... but for now, it seems to be working at least! (haven't tried with 10GbE speeds yet as I'm still waiting for the 10GbE card for the NAS)
 
Joined
Jan 24, 2018
macOS
10.14.2
Mobo
Gigabyte Z370 Aorus Gaming 7
CPU
Intel i7-8700K
GPU
Asus Radeon RX 580
#4
Update!

Finally got the 10GbE card for the NAS... I'm getting 500mb/s write and 540mb/s read and that's via cat 5e cables!

But I still have to restart the Hackintosh sometimes for the Sonnet Solo 10G to be initialised and working, which is a bit annoying...
 

Macfan

New member
Joined
Nov 9, 2019
macOS
10.15.0
Mobo
Gigabyte Z390 Designare
CPU
Intel i5 - 3.7 GHz
GPU
Sapphire RX-580 Nitro
#5
Hi DmitriZ
I understand you also have one: GC-TITAN RIDGE, cart.
I also have a Gigabyte GC-Titan Ridge, PCIE-Cart.
But is somewhat confused about the cables provided (THB_C header Cable X1) See possible pictures from website: https: //www.gigabyte.com/Motherboard/GC-TITAN-RIDGE-rev-10#kf
I can't find anywhere on my Gigabyte Designare Z390.
where the supplied cable: THB_C header Cable X1 can fit ?,
The onboard USB Type-C ™ header for USB 3.1 Gen2 which is on the Designare Z390 does not fit: GC-TITAN-RIDGE supplied cable ?.
Hope you understand my question. Excuse my bad English
 

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.15.5
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
Powercolor RX 580 8GB
#6
@Macfan
Try using the attached SSDT's in your /CLOVER/ACPI/Patched folder. They are from a thread where I helped another member of this site, who had the same motherboard as you, with an RX 580 GPU. His CPU was different but that shouldn't effect the use of the SSDT's.

Here is a link to the other thread - https://hackintosher.com/forums/thread/efi-check.1276/.

It is a fairly long thread/read but fairly informative for anyone with a Gigabyte Z390 Designare motherboard.
 

Attachments

Macfan

New member
Joined
Nov 9, 2019
macOS
10.15.0
Mobo
Gigabyte Z390 Designare
CPU
Intel i5 - 3.7 GHz
GPU
Sapphire RX-580 Nitro
#7
Edhawk
Thanks for your answer / info. I will test attached (SSDT_Designare_Z390) later.
But the problem is more the cable provided:
(THB_C header Cable X1) Supplied with AC-Titan Ridge.
It does not fit in the counted, THB_C header connection on the Designare Z390 ?. The intention is that this cable should be mounted. Or did I misunderstand this ?. See the attached pictures: THB-C Header.zip
 

Attachments

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.15.5
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
Powercolor RX 580 8GB
#8
No you haven't missunderstood anything.

That cable is supposed to be connected from the THB card to the motherboard THB header port, it provides the USB-C port with power etc.

Loking at the two images I don't see any issues with the cable connecting to the THB header. There should be one connector that matches the port on the THB card and there are two others. One of the two other connectors should be connected to the THB card, depending on which type of THB header your board uses.

I have attached a copy of the installation manual for the Alpine Ridge card, which explains this.
 

Attachments

Joined
Jul 31, 2020
macOS
10.14.6
Mobo
AORUS Z370 Ultra Gaming
CPU
i7 8700k
GPU
XFX 570
#9
Macfan or anyone else, I’d be willing to buy your THB_C cable off of you if you didn’t use it. I purchased a used Titan Ridge and can’t find that cable anywhere.