Gigabyte H77 Wifi ITX, I am so close........

drw1710

New member
Joined
May 19, 2020
macOS
10.15.5
Mobo
Asus Z370
CPU
I5 9400
GPU
AMD RX 550
#1
I decided I needed to try a different setup, the Z370 build is a major headache. This setup is a Gigabyte H77 with an I7 3770 with HD 4000 graphics.

This board has been far less difficult than the Z370. I do however have a few nagging issues.
1. Wifi Is perfect but there is no bluetooth BCM94352 (dell)DW 1550

2. The display resolution is not correct, I am not able to see the top of the screen, I have to search around blindly to see anything on the top bar and there is no underscan to correct it. Not to mention the available resolutions are limited. the system thinks I have a 30 inch display when in fact I am using my 55 inch led tv

3. I have no HDMI, the front and rear audio work fine.

any assistance is greatly appreciated and will be rewarded...Thank you
 

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.15.5
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
Powercolor RX 580 8GB
#2
You need the BrcmPatchRam kexts for the Bluetooth to work, they can be downloaded from this site - https://bitbucket.org/RehabMan/os-x-brcmpatchram/downloads/

See this link for installation procedure- https://github.com/RehabMan/OS-X-BrcmPatchRAM#installation

I would need to see a copy of your current CLOVER folder and the ACPI tables from your Ivy Bridge system before offering a solution to the graphics issue.

The ACPI tables can be obtained by pressing the F4 key wile on the Clover boot screen. The tables are extracted in the background with no indication it is happening. The tables will be saved to the /CLOVER/ACPI/origin folder on the EFI partition of your macOS or USB drive, whichever you use to boot the system.
 

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.15.5
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
Powercolor RX 580 8GB
#3
HDMI/Audio:
MacOS has no built-in volume controls for HDMI or DisplayPort audio. If you want audio controls within macOS for HDMI you need to use a third-party app such as Rogue Amoeba's SoundSource - https://rogueamoeba.com/soundsource/. You can use this app in it's free trial mode to see if it is worth purchasing, but it only works for around 20 minutes after booting the system.

The only other way to manage HDMI or DP audio under macOS is via the controls on the display or with the TV remote.

If you don't have HDMI audio working then you probably need to install Lilu.kext and WhateverGreen.kext, if they are not already installed. WhateverGreen.kext should enable HDMI audio for your IGPU if the correct framebuffer is being injected. For your Intel HD 4000 with no Discrete GPU you would need to use - AAPL,ig-platform-id: 05006201 in the devices section of your config.plist.

You may want to have a read of this post regarding framebuffer patching - https://github.com/acidanthera/WhateverGreen/blob/master/Manual/FAQ.IntelHD.en.md

And this post over at Tonymacx86 - https://www.tonymacx86.com/threads/...ching-guide-hdmi-black-screen-problem.269149/
 

drw1710

New member
Joined
May 19, 2020
macOS
10.15.5
Mobo
Asus Z370
CPU
I5 9400
GPU
AMD RX 550
#4
Here are the files you requested, Thank you so much
 

Attachments

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.15.5
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
Powercolor RX 580 8GB
#5
Here is partial CLOVER folder for you to try:

I have populated the /CLOVER/ACPI/patched folder with these SSDT's:
  • SSDT-EC.aml
  • SSDT-HPET.aml
  • SSDT-PLUG.aml
  • SSDT-XOSI.aml
The EC, HPET and PLUG SSDT's were generated using the DSDT you provided and CorpNewt's SSDTTime script. The SSDT's and patches etc. generated by the script are contained in the Results folder attached.

I have provided a revised config.plist, which I think will better suit your system.

I have provided a copy of the Catalina boot theme, in the /CLOVER/themes folder, as this is called by the config.plist.

I have attached a sample Other folder that contains some of the kexts you should be injecting for this system. I haven't included an Ethernet kext as I don't know which motherboard you are using.

Try these offerings and see if they help.
 

Attachments

drw1710

New member
Joined
May 19, 2020
macOS
10.15.5
Mobo
Asus Z370
CPU
I5 9400
GPU
AMD RX 550
#6
I added the platform id you listed and I know have HDMI audio
 

drw1710

New member
Joined
May 19, 2020
macOS
10.15.5
Mobo
Asus Z370
CPU
I5 9400
GPU
AMD RX 550
#7
This particular motherboard is a Gigabyte H77 wifi Itx
The remaining issues are
No bluetooth
and the graphics not scaling/improper resolution options
I can't see the top edge of the screen.

I7 3770
16gb ram
HD 4000 graphics
dell DW-1550 Broadcom BCM 94352( I was under the impression this one would work out of the box)
Sata drive
 
Last edited:

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.15.5
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
Powercolor RX 580 8GB
#8
Post a copy of your current CLOVER folder and I will have a look to see what needs changing, working blind isn't beneficial to either of us.

The DW 1550 will work out of the box, but not on every system. It depends on how it is connected, whether the USB port for the Bluetooth module has been correctly configured and activated.

Is the SATA drive a Spinning Hard Drive or an SSD? Is it connected to one of the two SATA 3 (6GB) ports? Or one of the two SATA II (3GB) ports?

Confirm which country you live in, as this can effect how the WiFi works, an additional Boot argument may be required to get the WiFi configured correctly for your country.

Have you ever created either of the following for your system:
  • CPU Power Management SSDT
  • USB SSDT-UIAC.aml or USBPorts.kext
 

drw1710

New member
Joined
May 19, 2020
macOS
10.15.5
Mobo
Asus Z370
CPU
I5 9400
GPU
AMD RX 550
#9
my country USA
SSD
sata 2
no to the last 2 questions
and after I powered up his morning, no more HDMI
 
Last edited:

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.15.5
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
Powercolor RX 580 8GB
#10
Post a copy of your current CLOVER folder and I will have a look at what you are using to see what needs tweaking to get it booting as well as it can.
 

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.15.5
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
Powercolor RX 580 8GB
#11
Have a look in System Preferences > Sound > Output tab, make sure the HDMI device is selected otherwise you won't have any audio from the TV.

Screenshot 2020-06-22 at 13.33.55.png


The screenshot above is from my iMac 1 system with the DisplayPort Audio selected. Your's will be slightly different and your TV should be listed as one of the Output sources.
 

drw1710

New member
Joined
May 19, 2020
macOS
10.15.5
Mobo
Asus Z370
CPU
I5 9400
GPU
AMD RX 550
#12
taking a. break on this for a bit, work is eating to much time to do 2 of these at once.
but for the record, there is no TV/monitor option for sound output
 

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.15.5
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
Powercolor RX 580 8GB
#13
OK, come back when you are ready and we can concentrate on one system at a time.
 

drw1710

New member
Joined
May 19, 2020
macOS
10.15.5
Mobo
Asus Z370
CPU
I5 9400
GPU
AMD RX 550
#14
Ok, the Asus is done, nothing left to tweak as far as I Know.

The Gigabyte H77 has one issue remaining and that is the wifi/BT. I used Open core in an attempt to get the os up and running, it worked well with this one exception.
 
Last edited:

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.15.5
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
Powercolor RX 580 8GB
#15
Which WiFi/BT card are you using?
Is the USB port the Bluetooth side of the card uses activated in your system?

Assuming you are using a Broadcom WiFi module I would recommend you install AirportBrcmFixup.kext (Lilu.kext plugin for Broadcom WiFi), see if that helps with the WiFi, a copy of the latest kext is attached.

You may want to add the following boot argument so the correct country specs are activated with the WiFi - brcmfx-country=GB

An explanation of what the kext does and the other optional boot arguments can be seen on this page - https://github.com/acidanthera/AirportBrcmFixup

I need more information regarding the Bluetooth, to know what you need to do to fix that part.
 

Attachments

drw1710

New member
Joined
May 19, 2020
macOS
10.15.5
Mobo
Asus Z370
CPU
I5 9400
GPU
AMD RX 550
#16
I installed the kext you have provided but the wifi adapter is still not viewable.
is there anything else I should have done besides placing the kext file in the kext folder?
I am in the USA should I just change the GB to USA ?

Dell DW1550 TVFF3 Broadcom BCM94352HMB is the wifi adapter I am using
 

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.15.5
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
Powercolor RX 580 8GB
#17
Change the GB to US.
 

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.15.5
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
Powercolor RX 580 8GB
#18
I’m using a similar if not identical WiFi/BT card in one of my laptop hacks, I’ll check what settings, kext, patches etc I have used and get back to you.
 

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.15.5
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
Powercolor RX 580 8GB
#19
Did you add the kext details to your OC config.plist?

Just adding the kext to the /OC/Kext folder won’t work, it needs to be listed in the config for the kext to be loaded.
 

drw1710

New member
Joined
May 19, 2020
macOS
10.15.5
Mobo
Asus Z370
CPU
I5 9400
GPU
AMD RX 550
#20
Yes I only added it to the KEXT folder, I will have to figure out how to update the plist.
 

Latest posts