HDD reacting as External HDD

Joined
Jul 12, 2019
macOS
10.15.5
Mobo
Gigabyte Z68 Ap D3 Rev.1
CPU
Intel i5 2500k
GPU
Gigabyte Radeon RX 560OC
#1
Hai, I have successfully installed Catalina 10.15.5 on my configuration. I was facing Random Freeze issue, then I got this to make it stable
<dict>
<key>Comment</key>
<string>fix I/O error for ICH10 - sfinktah</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>g+b+ZoXJD5jAQQjEdQtEifjB6BqD4AEJxg==</data>
<key>InfoPlistPatch</key>
<false/>
<key>MatchOS</key>
<string>10.15.x</string>
<key>Name</key>
<string>AppleAHCIPort</string>
<key>Replace</key>
<data>g+b+ZoXJD5jAQQjEdgtEifjB6BqD4AEJxg==</data>
</dict>
<dict>
<key>Comment</key>
<string>fix I/O error for ICH10 - sfinktah</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>icqB4kBgAgCB+kAgAAB1DIHhv3///4mLaQEAAA==</data>
<key>InfoPlistPatch</key>
<false/>
<key>MatchOS</key>
<string>10.15.x</string>
<key>Name</key>
<string>AppleAHCIPort</string>
<key>Replace</key>
<data>kJCQkJCQkJCQkJCQkJCQkJCQkJCQkJCQkJCQkA==</data>
</dict>


After adding this to my config.plist, my system is working perfectly.. no Random Freeze now. But my all Internal SSD icon changed to External HDD. See attachment

and my Front USB Ports are not working,.. back are working but my Front USB Ports are not working... earlier these were working but now not. see attachment

Kindly help me to resolve this....
Thanks in advance.
 

Attachments

Joined
Jul 12, 2019
macOS
10.15.5
Mobo
Gigabyte Z68 Ap D3 Rev.1
CPU
Intel i5 2500k
GPU
Gigabyte Radeon RX 560OC
#2
Hai, I have successfully installed Catalina 10.15.5 on my configuration. I was facing Random Freeze issue, then I got this to make it stable
<dict>
<key>Comment</key>
<string>fix I/O error for ICH10 - sfinktah</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>g+b+ZoXJD5jAQQjEdQtEifjB6BqD4AEJxg==</data>
<key>InfoPlistPatch</key>
<false/>
<key>MatchOS</key>
<string>10.15.x</string>
<key>Name</key>
<string>AppleAHCIPort</string>
<key>Replace</key>
<data>g+b+ZoXJD5jAQQjEdgtEifjB6BqD4AEJxg==</data>
</dict>
<dict>
<key>Comment</key>
<string>fix I/O error for ICH10 - sfinktah</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>icqB4kBgAgCB+kAgAAB1DIHhv3///4mLaQEAAA==</data>
<key>InfoPlistPatch</key>
<false/>
<key>MatchOS</key>
<string>10.15.x</string>
<key>Name</key>
<string>AppleAHCIPort</string>
<key>Replace</key>
<data>kJCQkJCQkJCQkJCQkJCQkJCQkJCQkJCQkJCQkA==</data>
</dict>


After adding this to my config.plist, my system is working perfectly.. no Random Freeze now. But my all Internal SSD icon changed to External HDD. See attachment

and my Front USB Ports are not working,.. back are working but my Front USB Ports are not working... earlier these were working but now not. see attachment

Kindly help me to resolve this....
Thanks in advance.
Hai Dear, I am still waiting for the response because my front ports are not working. So it is very difficult for me to put pen drive backside every-time.
 

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.15.5
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
Powercolor RX 580 8GB
#3
Try adding this patch to the KextToPatch section of your config.plist:

<dict>
<key>Comment</key>
<string>External icons patch</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>RXh0ZXJuYWw=</data>
<key>InfoPlistPatch</key>
<false/>
<key>Name</key>
<string>AppleAHCIPort</string>
<key>Replace</key>
<data>SW50ZXJuYWw=</data>
</dict>

Looks like this in Clover Configurator:

Screenshot 2020-07-06 at 22.54.15.png Clover config Kernel and Kext Patches tab, External Icons patch highlighted

Screenshot 2020-07-06 at 22.54.25.png
 
Joined
Jul 12, 2019
macOS
10.15.5
Mobo
Gigabyte Z68 Ap D3 Rev.1
CPU
Intel i5 2500k
GPU
Gigabyte Radeon RX 560OC
#4
Try adding this patch to the KextToPatch section of your config.plist:

<dict>
<key>Comment</key>
<string>External icons patch</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>RXh0ZXJuYWw=</data>
<key>InfoPlistPatch</key>
<false/>
<key>Name</key>
<string>AppleAHCIPort</string>
<key>Replace</key>
<data>SW50ZXJuYWw=</data>
</dict>

Looks like this in Clover Configurator:

View attachment 9730 Clover config Kernel and Kext Patches tab, External Icons patch highlighted

View attachment 9731
Thank you, Thank you, Thank you so much...
May God bless you dear...
Thanks again
 

Latest posts