Help msi z390 gaming pro carbon motherboard stuck on this

bob5967

New member
Joined
May 14, 2021
macOS
10.16.0
Mobo
msi z390 gaming pro carbon
CPU
i7 9700k
GPU
intel hd graphics 630
#1
Hi I'm trying to get my msi z390 gaming pro carbon motherboard to boot but it keeps getting stuck on this, it has intel hd 630 graphics. I have attached my efi.
IMG_0070.jpg
 

Attachments

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.15.7
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
Powercolor RX 580 8GB
#2
Where is your /EFI/OC/Kexts folder? Are you not using any kexts in your setup?

You should have Lilu.kext and VirtualSMC.kext as a minimum in the Kexts folder.

I would expect with your MSI Z390 board that you would also have these kexts in your /EFI/OC/Kexts folder:
  • AppleALC.kext - Audio fixes
  • IntelMausi.kext - Ethernet
  • USBInjectAll.kext - USB ports
  • WhateverGreen.kext - Graphics fixes
These four plus Lilu andVirtualSMC should also have an entry in your config.plist in the Kernel > Add section, yours is completely empty!

You need to read and go through the Gathering Files section of the OC guide, again. As you have missed a very important and essential part of the setup - https://dortania.github.io/OpenCore-Install-Guide/ktext.html
 

bob5967

New member
Joined
May 14, 2021
macOS
10.16.0
Mobo
msi z390 gaming pro carbon
CPU
i7 9700k
GPU
intel hd graphics 630
#3
Where is your /EFI/OC/Kexts folder? Are you not using any kexts in your setup?

You should have Lilu.kext and VirtualSMC.kext as a minimum in the Kexts folder.

I would expect with your MSI Z390 board that you would also have these kexts in your /EFI/OC/Kexts folder:
  • AppleALC.kext - Audio fixes
  • IntelMausi.kext - Ethernet
  • USBInjectAll.kext - USB ports
  • WhateverGreen.kext - Graphics fixes
These four plus Lilu andVirtualSMC should also have an entry in your config.plist in the Kernel > Add section, yours is completely empty!

You need to read and go through the Gathering Files section of the OC guide, again. As you have missed a very important and essential part of the setup - https://dortania.github.io/OpenCore-Install-Guide/ktext.html
ok thanks don't know how I managed to miss that step, I have added them now but its getting stuck on this now.
IMG_0072.jpg
 

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.15.7
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
Powercolor RX 580 8GB
#4
Post a copy of your new OC folder.

Have you made sure the kexts are all entered in the Kernel > Add section of your config.plist?
 

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.15.7
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
Powercolor RX 580 8GB
#5
Do you have the XhciPortLimit quirk set to True/Enabled?
 

bob5967

New member
Joined
May 14, 2021
macOS
10.16.0
Mobo
msi z390 gaming pro carbon
CPU
i7 9700k
GPU
intel hd graphics 630
#6
Post a copy of your new OC folder.

Have you made sure the kexts are all entered in the Kernel > Add section of your config.plist?
Hi yes they all seem to be added.
 

Attachments

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.15.7
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
Powercolor RX 580 8GB
#7
I have tweaked the attached EFI Folder to better suit your Coffee Lake & Z390 system, try this in place of your current EFI, see where it gets you.
 

Attachments

bob5967

New member
Joined
May 14, 2021
macOS
10.16.0
Mobo
msi z390 gaming pro carbon
CPU
i7 9700k
GPU
intel hd graphics 630
#8
I have tweaked the attached EFI Folder to better suit your Coffee Lake & Z390 system, try this in place of your current EFI, see where it gets you.
with that one it gets to the install screen I believe but my screen just goes black
 

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.15.7
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
Powercolor RX 580 8GB
#9
Are you using the DisplayPort or HDMI connector from your motherboard's I/O plate?

Can you change the display connection to DisplayPort if using HDMI? As usually DisplayPort connections work better in macOS.
 

bob5967

New member
Joined
May 14, 2021
macOS
10.16.0
Mobo
msi z390 gaming pro carbon
CPU
i7 9700k
GPU
intel hd graphics 630
#10
Are you using the DisplayPort or HDMI connector from your motherboard's I/O plate?

Can you change the display connection to DisplayPort if using HDMI? As usually DisplayPort connections work better in macOS.
hi sorry for the late reply I have tried both hdmi and DisplayPort and they both do the same
 

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.15.7
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
Powercolor RX 580 8GB
#11
Can you check you have your Bios set as shown below:

OC Bios settings

Disable
  • Fast Boot
  • Secure Boot
  • Serial/COM Port/Super IO port
  • Parallel Port
  • VT-d
  • CSM
  • Thunderbolt
  • Intel SGX
  • Intel Platform Trust
  • CFG Lock (MSR 0xE2 write protection) This must be off, if you can't find the option then enable AppleXcpmCfgLock under Kernel -> Quirks. Your hack will not boot with CFG-Lock enabled.
    • For 10.10 and older, you'll need to enable AppleCpuPmCfgLock Quirk as well
Enable
  • VT-x
  • Above 4G decoding
  • Hyper-Threading
  • Execute Disable Bit
  • EHCI/XHCI Hand-off
  • OS type: Windows 8.1/10 UEFI Mode
  • SATA Mode: AHCI
Your system may not have all these settings, some may be hidden within other settings, CSM and UEFI booting being the ones to spring to mind.

As you are only using the Intel iGPU, use these graphics settings:

Intel iGPU:
  1. Integrated Graphics : Enabled
  2. Graphics: IGD/Integrated/iGPU/CPU Graphics
  3. DVMT Pre-Allocated : 128M or higher
 

bob5967

New member
Joined
May 14, 2021
macOS
10.16.0
Mobo
msi z390 gaming pro carbon
CPU
i7 9700k
GPU
intel hd graphics 630
#12
Hi sorry been a bit busy just tried it now and it still goes to just a black screen