intel u630 no acceleration on high sieera / coffe lake board

athiqbe

New member
Joined
Feb 3, 2020
macOS
10.15.1
Mobo
hp 84f8 (u3e1)
CPU
corei7 8750
GPU
intel u630 and nvidia 1050 (4g)
#1
the title say it all .. i have two same laptops .. the first i installed catalina with the help of one of the admins here ... the second one i installed high sieera in and everything works fine .. just the intel uhd 630 show 7 mb only .. i followed many tutorials .. to change values in clover configurator and to install intel fake .. something .. but with no success / i used the same clover plist that i got from the admin here ,,, it works great for catalina but not so much for high sierra .. i changed some values like smbios and such but with no success maybe im just too dump .. you will see the clover efi file .. attached to check it out .. and i want to ask also what is the right way to install nvidia web drivers for laptop that has two gpus /1 is intel uhd 630 and the second one is nvidia 1050 .. and thank you in advanced ,, i already learned a lot about clover and about hackintosh via this site ,,
 

Attachments

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.15.1
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
Powercolor RX 580 8GB
#2
You are using a Coffee Lake IGPU/CPU that the OS doesn't support out of the box (OOB). You need to fake the IntelGFX as a Kaby Lake 0x59128086 in High Sierra.

You also need to set the AAPL,ig-platform-id or ig-platform-id similarly for full IGPU acceleration. I would try using the ig-platform-id for an i7-7700(k).

The Intel 8700 and 8700K series of CPU/IGPU's work out of the box with Mojave 10.14.5 upwards. This is why you didn't have the same issues with Catalina, as the CPU is supported OOB in that OS.

They do not work OOB with High Sierra, as Apple don't have a system using this or a similar CPU running High Sierra in any of their older MacBook Pro's.

You would need different SMBIOS's for the two laptops, one with the Coffee Lake CPU and the problematic one using a Kaby Lake compatible SMBIOS.
 
Likes: athiqbe
Joined
Feb 3, 2020
macOS
10.15.1
Mobo
hp 84f8 (u3e1)
CPU
corei7 8750
GPU
intel u630 and nvidia 1050 (4g)
#3
thank you so much .. for the replay ... with your instructions i got it working .. and now i understand more about how clover works .. but damn its complicated ..
 
Joined
Apr 10, 2018
macOS
10.15.1
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
Powercolor RX 580 8GB
#4
It’s not that complicated, well not after a few years and multiple hacks.

Just wait till we are all using OpenCore. Then everyone will find out what complicated really means.