Investigating random freezes

PGC77

New member
Joined
Jan 22, 2018
macOS
10.13.2
Mobo
Gigabyte Z370 Aorus Gaming 7
CPU
i7 8700K
GPU
Gigabyte GeForce GTX 1080 Ti Gaming OC 11G
#1
Hi everyone

I built my first Hackintosh earlier this year following this build guide: https://hackintosher.com/builds/gigabyte-z370-aorus-gaming-7-hackintosh-build-guide/

99% of the time, it works very well but from time to time, especially under very heavy workload (e.g.rendering in Adobe Media Encoder or rendering with Render Garden (Render Plugin for After Effects)) my Hackintosh crashes. There is no warning, no error or anything like that. The machine just shuts down immediately.

I would like to do some investigation on what can cause these freezes but I don't know where to start. I opened the console but there are so many entries, I have no clue on what to search for.

Any help is greatly appreciated!
 
Joined
Jan 18, 2019
macOS
10.13.6
Mobo
Z370 Auros Gaming Wifi
CPU
Coffee Lake i7-8700K 4.7GHz 12M
GPU
Geforce GTX 1070
#2
Hey PGC77, I'm having a very similar problem and I have the same mobo and CPU. It was recommended to me elsewhere in this forum (though it did not work for me) to add the boot arg shikigva=60 (others have suggested shikigva=28) and add the most recent version of shiki.kext to /L/E to help with some gpu crashes. I also read that switching everything from metal/opencl to CUDA seems to work. I get virtually no hang/reboot in the adobe suite after these changes, though davinci resolve continues to kill the whole system after only a few minutes. Hope this helps