NVIDIA HDMI Audio with AppleALC

jcosx69

New member
Joined
Aug 23, 2018
macOS
10.13.6
Mobo
Lenovo Thinckcentre m73
CPU
Core i3
GPU
geforce 210
#62
Hi, I have a Lenovo thinkcentre m73 with Geforce 210 1 gb vram, internal audio is working with appleALC.kext and Lilu.kext, but it takes above 4 minutes to boot because it runs four timeouts all of them are caused by HDMI and it doest work, I´ve already installed FakePCIID.kex and NvidiaGraphicsFixup.kext, somehow it now detects HDMI hardware but still they do not work and takes that amount of time to get the desktop, this is the real problem; since I don´t use HDMI (I have a DVI display with RCA audio plugs) it not mandatory for me to have HDMI enabled all the time, it just takes A LOT OF TIME to reach the desktop. Can anybody give me a hand with this? (I attached the registry explorer file of this machine) Thank you in advance.
 

Attachments

Joined
Mar 2, 2018
macOS
Mobo
GA-H97N-WIFI
CPU
i5 4600
GPU
Sapphire Pulse RX580
#63
it just takes A LOT OF TIME to reach the desktop. Can anybody give me a hand with this? (I attached the registry explorer file of this machine) Thank you in advance.
The following kexts have been merged into WhateverGreen and should be removed, check /Library/Extensions for:
  • NvidiaGraphicsFixup
  • Shiki
  • IntelGraphicsFixup
Also remove AppleALC from /Library/Extensions if there is an additional copy there.

After modifying kext contents in system folders run

Code:
sudo kextcache -i /
 

jcosx69

New member
Joined
Aug 23, 2018
macOS
10.13.6
Mobo
Lenovo Thinckcentre m73
CPU
Core i3
GPU
geforce 210
#64
Thanks for your answer Vulgo, I´ve followed your indications, also removed codeccommander.kext without positive results, it still goes four times in timeout.
 

Attachments

ehsan58

New member
Joined
Oct 9, 2018
macOS
10.13.4
Mobo
Dell M6800
CPU
4810
GPU
K4100m
#65
i have nvidia k4100m builtin audio not work... can i use this? i have also tested with voodooHDA it will play noises when i connect my headphone