OpenCore Won't Boot Anything But Big Sur

swordsx48

New member
Joined
Apr 21, 2020
macOS
10.14.6
Mobo
MSI Z97 Gaming 7
CPU
i5-4690k
GPU
Sapphire RX Vega 56
#1
Hi! Hope you're doing well! My OpenCore will only boot Big Sur! I've heard and seen that it works with OSes back until 10.4. Is that all with the same kexts and config.plist? I have ensured the SecureBootPolicy is set to Disabled, and surprisingly, it was with my Big Sur too.

It won't boot my Mojave or my High Sierra installation.

Any help? Here's the panic
1609136018545.jpg


On a side note, stay away from Big Sur! It's ruined mine and many others' external Hard Drives and USB drives - including those with real Apple hardware. It took me 7 hours to fix and I almost lost client's footage.

Thanks in advance guys!
 

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.15.7
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
Powercolor RX 580 8GB
#2
The screen image above seems to state you have an earlier version of Lilu.kext and WhateverGreen.kext within the Prelinked Kernel.

Screenshot 2020-12-28 at 14.55.20.png


The newer versions in the /OC/Kexts folder are causing the kernel panic.

When switching to OC from CLOVER you have to remove the third-party kexts from the Prelinked Kernel, usually from /Library/Extensions and/or /System/Library/Extensions. as OC uses the kexts in the /OC/Kexts folder otherwise you end up with a kernel panic as you have found.

You need to boot in to the other OS's with Clover, and undertake the kext removal, kext cache rebuild and permission repairs, so you can use the OC kexts.

I assume you have seen the Clover conversion pages over at Dortania, if not have a read - https://github.com/dortania/OpenCore-Install-Guide/tree/master/clover-conversion
 

swordsx48

New member
Joined
Apr 21, 2020
macOS
10.14.6
Mobo
MSI Z97 Gaming 7
CPU
i5-4690k
GPU
Sapphire RX Vega 56
#3
Now I'm really confused - I checked /S/L/E and /L/E and found no instance of Lilu.kext or WhateverGreen.kext. I then did a search through my whole entire drive, and only found them in the downloads folder (barring the one in the OC Kexts folder and Clover Kexts folder)
I have no clue where this prelinked copy is present. Any ideas?
Finally got around to cleaning out those old kexts so I can finally have the newer versions injected - whether that be OC or Clover.