Radeon RX580 8GB (Fans problem)

Roxy248

New member
Joined
Jul 24, 2018
macOS
10.13.6
Mobo
GA-Z170-HD3
CPU
i7 6700K
GPU
Radeon RX580
#1
I install new GPU Sapphire Radeon RX580 Pulse 8GB, I notice that GPU fans are not working properly. When the system boot in the High Sierra 10.13.6, fans will stop spinning and after 5 minutes just one fan starts to spin and producing some weird annoying sizzling noises.

Except that everything works fine I run four HD monitors and I have very good results on BruceX, Geekbench test and also FCPX export H.264 with no problem. My PSU is Corsair RM650X.

Do you have any ideas how to solve this problem?

Thank you for your help!
 

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.15.5
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
Powercolor RX 580 8GB
#2
Are you monitoring your GPU's temperatures? Are they high or low so only one fan is needed to keep the GPU cool?

I use Rehabman's FakeSMC addons and hardware monitor app to check the temps, fans etc.

No idea what the 'sizzling noise' could be.

Have you checked that you don't have any cables hanging in front of the fans that are stopping them from running or touching something that is getting hot?
 

RogerK

New member
Joined
Oct 14, 2018
macOS
10.13.6
Mobo
Gigabyte Z370 AORUS Gaming 5
CPU
i5-8400
GPU
RX 580 8GB
#3
I've got a similar problem, but in my case, the fans on the RX580 spin until the login screen on bootup then stop. They don't seem to start again.
At idle, just browsing the web, the card seems to heat up a lot, and the heat tubes are very hot to the touch.

I'd like to know a way of keeping the fans on all the time, or getting them to kick in at say 40 degrees. How can that be achieved?

My rig is:
10.13.6, Gigabyte 370 AORUS Gaming 5, i5-8400, MSI RX580 Gaming X 8 GB
 
Joined
Jul 3, 2018
Mobo
ASUS Z370-E Gaming ROG Strix
CPU
Intel i7 7800k 3.7Ghz
GPU
Asus Strix gaming Radeon RX 580
#4
my Asus RX580 has a "feature" that turns the fans off until the temperature gets over 40 degrees Celsius. you can't change this setting unless you have a windows computer. so just enjoy the quietness
 
Joined
Dec 4, 2018
macOS
10.14.1
Mobo
ASUS Prime Z370-A
CPU
Intel i8700k
GPU
Sapphire RX580
#5
Just built myself a similar setup. Everything’s running fine for me except like you my Sapphire RX 580 isn’t spinning its fans. They spin on startup, then stop once I’m in MacOS. iStat shows GPU getting up toward 90 degrees at which point I get nervous and shut it down. Did you find a fix?
 
Joined
Jul 3, 2018
Mobo
ASUS Z370-E Gaming ROG Strix
CPU
Intel i7 7800k 3.7Ghz
GPU
Asus Strix gaming Radeon RX 580
#6
yeah It’s a feature, it even says it on the website of my GPU. It doesn’t turn the fans on unless it gets above 50 degrees. I was nervous at first but it’s great for quietness. Try playing some games and get it to 60 degrees and see if the fan turns on. Mine turns on at exactly 50 degrees
 
Likes: Gogeta-Blue
Joined
Dec 4, 2018
macOS
10.14.1
Mobo
ASUS Prime Z370-A
CPU
Intel i8700k
GPU
Sapphire RX580
#7
yeah It’s a feature, it even says it on the website of my GPU. It doesn’t turn the fans on unless it gets above 50 degrees. I was nervous at first but it’s great for quietness. Try playing some games and get it to 60 degrees and see if the fan turns on. Mine turns on at exactly 50 degrees
That’s probably the case, but my GPU climbs from about 70 degrees to 90degrees after booting into MacOS, and no fans spin up. Could it just be a driver issue you think?
 
Joined
Jul 3, 2018
Mobo
ASUS Z370-E Gaming ROG Strix
CPU
Intel i7 7800k 3.7Ghz
GPU
Asus Strix gaming Radeon RX 580
#8
How did you measure the temperature during bootup?

And how long is the GPU running at these temps?

And how are you managing to get your GPU so hot during bootup?
 
Joined
Dec 4, 2018
macOS
10.14.1
Mobo
ASUS Prime Z370-A
CPU
Intel i8700k
GPU
Sapphire RX580
#9
I’m running iStat Pro in MacOS to check temps. After login it usually says 70+ degrees, and five minutes thereafter climbs to 80-90, at which point I shut down the machine to prevent longer term damage.

I’m not doing anything on the GPU except running a Dell Ultrawide 1440 monitor.

In any case, I just installed Windows on a second disk, so I'll play around with the GPU bios there and see if I can get it to trigger any different behavior on the Mac side.
 

Pawel

New member
Joined
Feb 21, 2018
macOS
10.13.3
Mobo
ASrock Z370 Extreme 4
CPU
i7-8700K
GPU
Sapphire Radeon RX580 Pulse
#10
So did anyone found the way to control the fans without using Windows ? Is there any app that could change default setting on the fans, so let say they will turn on at 45C degrees ?
 

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.15.5
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
Powercolor RX 580 8GB
#11
I'm not sure if any of you have seen this post by 'Jaymonkey' over at Tonymacx86, it is related to a similar issue with AMD Vega cards - https://www.tonymacx86.com/threads/...vega-power-and-fan-control-properties.267519/

They have an app and method for creating a SoftPowerPlayTable. This SoftPowerPlayTable provides custom power and fan properties for the graphics card that removes the issues of overheating, no fans working etc.

It may be possible to do the same for your RX580 cards.