Random Freezes - H.Sierra 10.13.3 AsRock Z370 Extreme 4, i7-8700K

Pawel

New member
Joined
Feb 21, 2018
macOS
10.13.3
Mobo
ASrock Z370 Extreme 4
CPU
i7-8700K
GPU
Sapphire Radeon RX580 Pulse
#1
Hi Everyone,
Help Need it.
I'm experiencing random system freezes and I can't figure it out what is causing it ? Once it will freeze there is only restart option cause nothing else is working.
Beside that everything is working fine (exepct iTunes which is crashing) but I never know when it's gonna freeze which is bit annoying.
If any of You experience that and know the solution pls share.

My specs:
MOB: AsRock Z370 Extreme 4
CPU: Intel i7-8700K
GPU: Sapphire Radeon RX 580 8GB Pulse
RAM: Corsair 32GB 3000Mhz

I followed all guides from this site when installing system.
I'm attaching my Clover Configuration cause I'm pretty sure that I need to change sth there. Also sets of kexts that I'm using - all up to date.

ACPI.png
System Parameters.png
Kexts.png
Boot.png
CPU.png
Devices.png
Graphic.png
GUI.png
Kernel and Kext Patches.png
SMBIOS.png
 
Joined
Jan 22, 2018
macOS
10.13.3
Mobo
ASUS ROG Maximus X Hero
CPU
i7-8700k
GPU
AMD Radeon RX 560
#2
Setting shikigva=4 to shikigva=16 in boot resolved freezing for me. The freezing I experienced would freeze everything, but mouse would still move. Also Plex / iTunes would crash. Ever since the change had not had one crash or freeze. Try it, hope it works for you too! :)
 

Pawel

New member
Joined
Feb 21, 2018
macOS
10.13.3
Mobo
ASrock Z370 Extreme 4
CPU
i7-8700K
GPU
Sapphire Radeon RX580 Pulse
#3
Thanks KaBaDaBra ! I will try it. Also maybe new suplemental update that just came out will fix some problems. I will post the result :)
 
Joined
Mar 9, 2018
macOS
10.13.3
Mobo
Gigabyte Z370 Ultimate Gaming
CPU
8700K
GPU
Aorus RX 580 8GB
#4
Thanks KaBaDaBrA for the tip! I just registered an account just to say thank you. What you said is exactly what solved my problem! I was having issues all the time when the CPU or the system was running a lot of processes at the same time. The mouse would keep moving, but the screen wouldn't be responsive. Adding that boot setting fixed it for me! Thanks for posting your solution for everyone!

Thanks Pawel for sharing your problem too so that others could discover a solution for it!

Cheers!
 

Pawel

New member
Joined
Feb 21, 2018
macOS
10.13.3
Mobo
ASrock Z370 Extreme 4
CPU
i7-8700K
GPU
Sapphire Radeon RX580 Pulse
#5
Actually setting shikigva=16 didn't fully solve my freez problems. But I found on another forum one more tip that so far eliminated all the problems that I had.

So firstly I changed shiki value to shikigva=28 then using kextbeast app I placed (Lilu, Lilufriend, IntelGraphicFixup and Whatevergreen kexts in /Library/Extension. In BIOS Integrated Graphic set to enable and DVMT 128MB. Also I downloaded new FakeSMC.kext and keeping it in Clover/kext/Other.
Everything works perfectly now and iTunes is not crashing anymore !
Maybe this will help if anyone is still having problems.
 
Joined
Mar 9, 2018
macOS
10.13.3
Mobo
Gigabyte Z370 Ultimate Gaming
CPU
8700K
GPU
Aorus RX 580 8GB
#6
Pawel, thanks for the additional tip! Glad to hear your system is working perfectly for you! My system is running stable now also, but I'm having a problem playing DRM content in iTunes. I'm not sure if that's what you experienced also, but every time I play movie in iTunes, the screen goes black, but the audio still plays.
 

Pawel

New member
Joined
Feb 21, 2018
macOS
10.13.3
Mobo
ASrock Z370 Extreme 4
CPU
i7-8700K
GPU
Sapphire Radeon RX580 Pulse
#7
Well my problem with iTunes was that after l start the program it was crashing after short time about 10sek or sth. So I couldn't play any songs etc. Now it's not crashing at all. I can play music, watch films, browsing iTunes store. Maybe changing shigva to 28 is the right cure :)
 
Likes: Hotsticker
Joined
Mar 9, 2018
macOS
10.13.3
Mobo
Gigabyte Z370 Ultimate Gaming
CPU
8700K
GPU
Aorus RX 580 8GB
#8
Pawel, thank you brother! With shigva to 28, my system is stable and iTunes is working also! I have to download the movies to the computer before they're able to play, but at least they're able to play.

The only iTunes issue is, I'm not able to do the immediately playback DRM movies via streaming (right after clicking the play button). Does that function for you?
 

arena

New member
Joined
Jan 11, 2019
Mobo
ASRock z370 Extreme4
CPU
i7-8700K
GPU
Intel 630
#9
Hi Guys, can you please share your EFI folder with me? I have exactly the same config as you Pawel, but I am unable to install. Any help would be appreciated!
 
Joined
Jan 18, 2019
macOS
10.13.6
Mobo
Z370 Auros Gaming Wifi
CPU
Coffee Lake i7-8700K 4.7GHz 12M
GPU
Geforce GTX 1070
#10
Thanks for this update! I had heard on some other forum (possibly tonymac) to remove shiki because it didn't apply anymore to 10.13.6 after whatevergreen.kext anyone else have issues with that? I'm getting freezing and hang from resolve and the adobe suite though the issue sounds similar at it's source.
 

Latest posts