[Solved] Black Screen after Wake

Red200220

New member
Joined
Sep 12, 2019
macOS
10.14.6
Mobo
MRRJR
CPU
intel i5 3317U
GPU
Intel HD 4000 / AMD Radeon 7570M
Here is my clover boot file... I am sending all these individually because they are big in size...
 

Attachments

Red200220

New member
Joined
Sep 12, 2019
macOS
10.14.6
Mobo
MRRJR
CPU
intel i5 3317U
GPU
Intel HD 4000 / AMD Radeon 7570M
And there is one more issue... I donut know if hats an issue or not but my laptop turns really hot despite turning my amd GPU Off... Is there a fix for that??
 

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.14.6
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
2 x Powercolor RX 580 8GB
Most notable information in your Clover installation log is the following, purely from a view of understanding which drivers or kexts work with each other or not as the case may be:
  • VirtualSMC.efi is removed if SMCHelper.efi is selected.
  • HFSPlus.efi is removed if VBoxHfs.efi is selected or viceversa.
  • ApfsDriverLoader.efi is removed if apfs.efi is selected or viceversa.
  • Only one of OsxAptioFixDrv.efi, OsxAptioFix3Drv.efi, AptioMemoryFix.efi, OsxLowMemFixDrv.efi is allowed and any driver that match with "aptiofix", "memfix" or "memoryfix" will be deleted.
Your Extensions folder looks OK, no additional USB kext. Although I am curious about your use of the ApplePS2SmartTouchPad.kext in place of voodooPS2Controller.kext. Do you have a Synaptics touchpad?

You have USBMap.kext in your /CLOVER/kexts/Other folder. This kext needs to be removed, as it works the same as SSDT-UIAC.aml and USBPorts.kext.

Otherwise looks ok.
 

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.14.6
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
2 x Powercolor RX 580 8GB
The Apple and Boot folders are required. We never add or remove items from these folders, which is why I only ask for the CLOVER folder to be provided.

If you could provide a copy of your Bootlog file it would be helpful, as it shows what is being loaded or not when your system starts. This can be obtained from Clover Configurator, downloaded to the desktop, compressed and posted here.
 
Likes: Red200220

Red200220

New member
Joined
Sep 12, 2019
macOS
10.14.6
Mobo
MRRJR
CPU
intel i5 3317U
GPU
Intel HD 4000 / AMD Radeon 7570M
I know appleps2 is used if we have a synaptic touchpad but I thought its better than voodops2... I don't know if my trackpad is synaptic... how to find it??
 

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.14.6
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
2 x Powercolor RX 580 8GB
Look under Windows Device manager or look up the vendor/device ID in System Information. One or both should tell you if your touchpad is Synaptics, Elan or another make.

I have had a look at your Bootlog and have seen some issues that need to be resolved.
  1. Clovy Theme icons not loading correctly
  2. 2 No Obsolete kernel patches
  3. 5 No Obsolete DSDT/SSDT rename patches
  4. Wrong screen resolution set
  5. Hibernation issues for Drives - sleep image not found.
I will have a look at your config.plist and make the necessary changes for you to try.

I will provide some Terminal commands to deal with the Hibernation issues.

I will provide an alternative clover theme, which shouldn't have the icon issues that Clovy seems to have.
 
Likes: Red200220

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.14.6
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
2 x Powercolor RX 580 8GB
Here is the revised Clover folder for you to try.

Try it as it is, don't make any changes before you boot with this folder.

I need to see what is happening, so can you post another copy of your Bootlog, copied after you boot with this folder and also a copy of your IOReg. You will need to use v2.1 of IORegistry Explorer, copy attached.

Run the IOReg dmg and make sure the app is copied to the Applications folder on your laptop. Then run the app and navigate to File 'Save copy as' save it to your desktop, compress it and attach it to a post here.

I will get back to you regarding the Hibernation issues shortly.
 

Attachments

Likes: Red200220

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.14.6
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
2 x Powercolor RX 580 8GB
Actually this copy of IOReg may work better, the one attached above is a bit quirky.
 

Attachments

Likes: Red200220

Red200220

New member
Joined
Sep 12, 2019
macOS
10.14.6
Mobo
MRRJR
CPU
intel i5 3317U
GPU
Intel HD 4000 / AMD Radeon 7570M
Okk...
1- I put your clover folder instead of mine and booted from it... I have attached the bootleg.txt...
2- With your version of Ioreg, I saved the output to desktop...
3- I had Ioreg previously because I used to generate problem reporting files to ask my queries on tonymacx86 forums... So I also generated this time and attached the output....
4- There is a weird glitch when I boot macOS and that is the progress bar is shown incorrectly... I boot from my ssd and it boots fast.. but the progress bar is wrongly shown... so I recorded the boot attached...

PS- I am not able to send my boot up video as its 50 mb and this site is not allowing that..
so can you give me your mail or something on which I can share that...
 

Attachments

Red200220

New member
Joined
Sep 12, 2019
macOS
10.14.6
Mobo
MRRJR
CPU
intel i5 3317U
GPU
Intel HD 4000 / AMD Radeon 7570M
Okk...
1- I put your clover folder instead of mine and booted from it... I have attached the bootleg.txt...
2- With your version of Ioreg, I saved the output to desktop...
3- I had Ioreg previously because I used to generate problem reporting files to ask my queries on tonymacx86 forums... So I also generated this time and attached the output....
4- There is a weird glitch when I boot macOS and that is the progress bar is shown incorrectly... I boot from my ssd and it boots fast.. but the progress bar is wrongly shown... so I recorded the boot attached...

PS- I am not able to send my boot up video as its 50 mb and this site is not allowing that..
so can you give me your mail or something on which I can share that...
Ok I was able to compress the video and now its 5mb.... Please see it :)
 

Attachments

Red200220

New member
Joined
Sep 12, 2019
macOS
10.14.6
Mobo
MRRJR
CPU
intel i5 3317U
GPU
Intel HD 4000 / AMD Radeon 7570M
And one more thing, I have attached a video of my vendor id... can you tell me what is my touchpad...
 

Attachments

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.14.6
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
2 x Powercolor RX 580 8GB
Rather than the video, can you post a copy of your PCI output from Hackintool. The export feature will generate a number of files in different formats, i.e. a kext, a plist, an SSDT and another I can't remember. Zip them up and post them here.
 

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.14.6
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
2 x Powercolor RX 580 8GB
Regarding the distorted images I think that may be down to me removing one of the SSDT's, specifically the Cloverx64 SSDT. I removed it from the /CLOVER/ACPI/patched folder from the last Clover folder I posted. I wanted to see what would happen if it was removed, as I didn't know what it was in the folder to do.

Try adding it back in to the patched folder and see if the boot process is improved.
 

Red200220

New member
Joined
Sep 12, 2019
macOS
10.14.6
Mobo
MRRJR
CPU
intel i5 3317U
GPU
Intel HD 4000 / AMD Radeon 7570M
Regarding the distorted images I think that may be down to me removing one of the SSDT's, specifically the Cloverx64 SSDT. I removed it from the /CLOVER/ACPI/patched folder from the last Clover folder I posted. I wanted to see what would happen if it was removed, as I didn't know what it was in the folder to do.

Try adding it back in to the patched folder and see if the boot process is improved.
It was like that before when i used to boot from my clover....
So there are 2 problems, 1 is the distored image when osx boots up and 2 is the progress bar... when i installed mac os on this laptop fresh then the progress bar moved quickly because of the ssd...
 

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.14.6
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
2 x Powercolor RX 580 8GB
Your Bootlog is much improved. It is cleaner, and other than a pair of duplicate 'Exit from MainMenu 1' items, it would be exceptionally fast. These two entries take about 5.8 and 6.01 seconds (just under 12 seconds in total). The total time for your boot to complete is only 12.7 seconds, so without these two delaying entries your boot would be completed in around 1 second.

Your IOReg shows a few matters that may require attention if you want your system 100% Apple, but these items are not urgent nor are they related to your USB sleep issues. They are SATA and Ethernet related.

Your EH01, EH02 and XHC controllers are showing in the IOReg. How are the USB ports behaving when you sleep your laptop?
 

Red200220

New member
Joined
Sep 12, 2019
macOS
10.14.6
Mobo
MRRJR
CPU
intel i5 3317U
GPU
Intel HD 4000 / AMD Radeon 7570M
1- PCI Output from Hackintool just generated a txt file and nothing else....
2- When I put my laptop to sleep, it goes to sleep , my usb devices are turned off and then the laptop wakes from sleep immediately....
 

Attachments

Red200220

New member
Joined
Sep 12, 2019
macOS
10.14.6
Mobo
MRRJR
CPU
intel i5 3317U
GPU
Intel HD 4000 / AMD Radeon 7570M
Sorry didn't see it generated 2 more files... Ill zip every file and post them here...
 

Attachments

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.14.6
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
2 x Powercolor RX 580 8GB
Ok, I have downloaded the PCIDevice files and will have a look to see if they hold the information I'm looking for.
 
Likes: Red200220

Latest posts