[Solved] Problems to install macOS Catalina in Acer Aspire E1-572G

Joined
Feb 5, 2020
macOS
10.15.0
Mobo
EA50_HW
CPU
i7-4500U
GPU
HD 8750M
#1
Acer Aspire E1-572G-74508G50MNKK
Acer Aspire E1-572G-74508G50MNKK.PNG

The hard drive was completely wiped for an easier install.

The problem
IMG_20200211_012549.jpg

Clover UEFI loads sucessfully and I can boot to Install macOS Catalina 10.15.3.
After around 15-30 seconds after booting to Install macOS Catalina 10.15.3, the error appears.

Lastly, the most important part, the EFI folder.
Tried to make a config.plist as vanilla as possible so probably made something wrong in the process.
 

Attachments

Edhawk

Moderator
Joined
Apr 10, 2018
macOS
10.15.5
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
Powercolor RX 580 8GB
#2
Here is a CLOVER folder for you to use in place of your current one.

This one has been set for a Haswell laptop, not a Haswell desktop system. So it should work with your laptop.

FYI, the AMD dGPU will not work with macOS, eve. So I have added the WhateverGreen.kext boot argument -wegnoegpu, to disable the AMD graphics.

Your WiFi/BT card will not work with macOS, it will need to be removed and replaced with a compatible Broadcom WiFi/BT card.

No idea which Ethernet port you laptop uses so left the Relatek LAN driver in your /CLOVER/kexts/Other folder.

I ahve added a number of kexts to your /CLOER/kexts/Other folder:
  • ACPIBatteryManager.kext
  • AHCI_3rdParty_SATA.kext
  • AHCI_Intel_Generic_SATA.kext
  • AirportBrcmFixup.kext
  • AppleBacklightFixup.kext
  • Sinetek-rtsx.kext
Hopefully these kexts will help some of the other components show and work correclty in macOS.
 

Attachments

Joined
Feb 5, 2020
macOS
10.15.0
Mobo
EA50_HW
CPU
i7-4500U
GPU
HD 8750M
#3
Sucessfully installed macOS Catalina.
I will be testing it a little bit and start working on the post installation.
Will make a new post if I have some problems since this post was about pre installation issues.

Thanks for your effort.
 

Latest posts