Stuck at grey screen with a white box and cursor | Vanilla Catalina i7-7700k RX580 H270M-ITX/ac

Joined
Dec 11, 2019
macOS
10.15.1
Mobo
ASRock H270M-ITX/ac
CPU
i7-7700k
GPU
Radeon RX580
#1
I'm trying to install Catalina fresh onto my setup. I set up the installation USB via the Vanilla Hackintosh method.

However, every time I boot I get stuck on this page:

maqunkn0ol341.jpg


As you can see my cursor is on there; however, if I click on the white box then my cursor disappears permanently. It stays stuck on this screen indefinitely.

Before it goes into that state, this is what the verbose log output looks like:

as1fom7fol341.png


Here are the things I've tried:
  1. Rebuilding my installation USB - many times. I've tried with both the official Catalina installer and the Catalina Patcher too... no success either way.
  2. Adding Lilu/WhateverGreen - done that. Doesn't work. InjectKexts is set to YES if you are wondering.
  3. I am currently using the HDMI port on my dGPU, however I've also tried the DP port. The internal HDMI port doesn't give me anything.
  4. I've tried using both iMac18,1 and iMac18,3 - no difference, same issue.
  5. Booting into Windows. Windows recognises my RX580 just fine. Unigine Heaven scores are pretty normal too so I'm guessing that my graphics card is not the issue.
I can hear sound (the Mac "funk" sound when I press a key that's not allowed) so I'm guessing that it is a graphics issue.

I've attached my EFI/CLOVER directory (without themes) so you can see what I'm doing right now.

Any help / experience would be greatly appreciated.
 

Attachments