[Success][Guide] ASUS ROG Maximus X Hero Z370 Hackintosh Build

Hackintosher

Administrator
Joined
Jan 21, 2018
macOS
10.15.0
Mobo
Gigabyte Z370N WIFI
CPU
i3-8100
GPU
UHD 630 Graphics
#1
ASUS_ROG_MAXIMUS_HERO_X_HACKINTOSH.jpg


The Monitor: Dell Ultrawide U3417W

See original blog post: ASUS ROG Maximus X HERO Hackintosh Build Guide - Hackintosher

I always preferred ASUS motherboards over Gigabyte as they tend to be the only one without any hackintosh problems in my use case. This post also has a guide to it and contains my config.plist I used to get to this hackintosh up and running. Basically what you want to do is follow the general guide and replace the config.plist with the ASUS one which you can download at the bottom of this post and your good to go.

Parts
Here's the parts I used for this hackintosh.

MOBO: ASUS ROG Maximus X Hero (Wi-Fi AC)
https://www.amazon.com/Maximus-Hero...UTF8&qid=1517078554&sr=1-1&keywords=z370+hero
https://www.newegg.com/Product/Product.aspx?Item=N82E16813119032&cm_re=hero_x-_-13-119-032-_-Product

CPU: Intel Core i7-8700K Coffee Lake 6-Core 3.7 GHz (4.7 GHz Turbo)
https://www.amazon.com/Intel-BX80684I78700K-Core-i7-8700K-Processor/dp/B07598VZR8/
https://www.newegg.com/Product/Product.aspx?Item=N82E16819117827&cm_re=i7-8700k-_-19-117-827-_-Product

COOLER: NZXT Kraken X62AIO
https://www.amazon.com/G-SKILL-TridentZ-288-Pin-3000MHz-F4-3000C16D-16GTZR/dp/B06WP4L3D7/
https://www.newegg.com/Product/Product.aspx?Item=N82E16835146059

RAM: G.SKILL TridentZ RGB Series 16GB (2 x 8GB) DDR4 300MHz
https://www.amazon.com/G-SKILL-TridentZ-288-Pin-3000MHz-F4-3000C16D-16GTZR/dp/B06WP4L3D7/
https://www.newegg.com/Product/Product.aspx?Item=N82E16820232475&cm_re=gskill_trident_z_ddr4-_-20-232-475-_-Product

SSD: SAMSUNG 960 EVO M.2 250GB NVMe
https://www.amazon.com/Samsung-960-EVO-Internal-MZ-V6E500BW/dp/B01LYFKX41/
https://www.newegg.com/Product/Product.aspx?Item=N82E16820147593&cm_re=960_evo-_-20-147-593-_-Product

GPU: XFX GTS Black Core Edition Radeon RX 580
https://www.amazon.com/s/ref=nb_sb_noss?url=search-alias=electronics&field-keywords=XFX+GTS+RX+580
https://www.newegg.com/Product/Product.aspx?Item=9SIA6V66J47564&cm_re=RX_580_GTS-_-9SIA6V66J47564-_-Product

PSU: EVGA SuperNOVA 650 G3
https://www.amazon.com/EVGA-SuperNOVA-Modular-Warranty-220-G3-0650-Y1/dp/B01LYGFRL6/
https://www.newegg.com/Product/Product.aspx?Item=N82E16817438094&cm_re=EVGA_G3_650W-_-17-438-094-_-Product

Case: NZXT S340 Elite Matte White Steel/Tempered Glass ATX
https://www.amazon.com/S340VR-Elite-Computer-Matte-CA-S340W-W2/dp/B01LZ3BJ5U/
https://www.newegg.com/Product/Product.aspx?Item=N82E16811146239&cm_re=NZXT_S340_Elite-_-11-146-239-_-Product

WiFi: BCM94352Z
https://www.amazon.com/dp/B0156DVQ7G/


ASUS HERO Hackintosh Guide

Step 1 – Creating the macOS Installer

How to make a USB flash drive installer for macOS - Hackintosher

Step 2 – Configure EFI Boot Partition
  1. Download Clover Configurator
  2. Open Clover Configurator
  3. Select Mount EFI under TOOLS
  4. Click Mount Partition for Install macOS….
  5. Click Open Partition (This is your EFI Folder)
  6. Delete the existing EFI folder if it’s in the partition
  7. Download Hackintosher’s High Sierra EFI.zip
  8. Unzip High Sierra EFI.zip
  9. Copy & Paste the unzipped EFI folder to mounted partition or /Volumes/EFI
Step 3 - Recommended BIOS Settings
Before running the macOS installer change these settings.
Restart your computer and press the DEL key to enter BIOS upon your computer posting.

Change the following settings for the install:
  1. Exit → Load Optimized Defaults : Yes
  2. Advanced \ CPU Configuration → Intel Virtualizaiton Technology: Enabled
  3. Advanced \ System Agent (SA) Configuration → Vt-d: Disabled
  4. Advanced \ PCH Configuration → IOAPIC 24-119 Entries: Enabled
  5. Advanced \ Onboard Devices Configuration → RGB LED Lighting → When system is in sleep, hibernate or soft off states: OFF
  6. Advanced \ AMP Configuration → Power On By PCI-E/PCI: Enabled
  7. Advanced \ Network Stack Configuration → Network Stack: Disabled
  8. Advanced \ USB Configuration -> Legacy USB Support: Auto
  9. Boot → Fast Boot : Disabled
  10. Boot → Secure Boot → OS Type : Other OS
Using a dedicated graphics card:
  1. Advanced \ System Agent (SA) Configuration \ Graphics Configuration → Primary Display: PEG
Using Intel iGPU:
  1. Advanced \ System Agent (SA) Configuration \ Graphics Configuration → Primary Display: IGFX
(Optional) Hardware Acceleration

iGPU Multi-Monitor: Enabled will cause Primary Display to be set to IGFX. If you are using a dedicated graphics card change it back to PEG
  • Advanced \ System Agent (SA) Configuration\Graphics Configuration → iGPU Multi-Monitor: Enabled
For DVMT Pre-Allocated to show in BIOS you may need to save & reenter BIOS after setting iGPU Multi-Monitor: Enabled
  • Advanced \ System Agent (SA) Configuration\Graphics Configuration → DVMT Pre-Allocated: 128MB/192MB
Setting Boot Device:

You’ll want to be using the USB Flash Drive as the primary boot device until your hard drive becomes bootable at the end of Step 6. There are two ways to go about doing this:

Option 1: Press F8 on startup each time to select a temporary boot device until the boot partition on the drive you install macOS is configured. If you want to do temporary booting you will select the version of your USB Drive starting with UEFI: in it’s name. (For example I used a SanDisk flash drive so I would select UEFI: Sandisk, Partition 1)

Option 2: Enter BIOS and set Boot → Boot Option #1: UEFI : XXX (For example I used a SanDisk flash drive so I would select UEFI: Sandisk, Partition 1) This is easier if you don’t want to spam F8 on startup every time to boot macOS.

Step 4 – Installing macOS

Mac OS High Sierra Hackintosh Install Clover Walkthrough - Hackintosher

Step 5 - ASUS Post Install

ASUS config.plist

Download one of the three config.plist attached to the bottom of this post depending on what graphics you are using. The config.plist also has the proper darkwake and audio-id for the S1220 chipset.

  1. Download config.plist at bottom depending on what graphics card you are using.
  2. Unzip config.plist
  3. Mount EFI partition
  4. Replace config.plist in Volumes/EFI/EFI/Clover/ with the ASUS one you downloaded from this page
  5. You'll then need to add the USB Patch to config.plist for any versions of macOS High Sierra you are installing for example the latest version is 10.13.6:
    1. https://hackintosher.com/guides/hackintosh-high-sierra-10-13-6-update-guide/#usb
Sleep:
  1. Open the Settings App
  2. Click Energy Saver
  3. Uncheck
  4. Uncheck Wake for Ethernet Network access
  5. Uncheck Enable Power Nap
If you have an Nvidia graphics card, follow:

How to properly Install Nvidia Drivers on High Sierra 10.13 - Hackintosher

WiFi:

If you installed the Broadcom BCM94352Z WLAN Card follow this to enabled:

https://hackintosher.com/forums/thr...h-cards-on-a-hackintosh-bcm94352z-bcm94322.6/
 

Attachments

Last edited:
Joined
Jan 22, 2018
macOS
10.13.3
Mobo
ASUS ROG Maximus X Hero
CPU
i7-8700k
GPU
AMD Radeon RX 560
#2
Awesome! Thank you 🙏😁 waiting for my parts to arrive and will be building a similar build.
 

yjppsw

New member
Joined
Feb 1, 2018
macOS
10.13.3
#5
Hi, I use your guide to install the Hackintosh. But I bought a GMYLE Bluetooth USB adapter.
But there is a problem. Every time I restart the Hackintosh, the Bluetooth is turned OFF. And I need to replug in the USB Bluetooth to make the Bluetooth ON. Do you know what is the problem is?

Thanks for your help.
 

Hackintosher

Administrator
Joined
Jan 21, 2018
macOS
10.15.0
Mobo
Gigabyte Z370N WIFI
CPU
i3-8100
GPU
UHD 630 Graphics
#7
Hi, I use your guide to install the Hackintosh. But I bought a GMYLE Bluetooth USB adapter.
But there is a problem. Every time I restart the Hackintosh, the Bluetooth is turned OFF. And I need to replug in the USB Bluetooth to make the Bluetooth ON. Do you know what is the problem is?

Thanks for your help.
That's the thing with dongles. I had the same problem when I used one. That's why I use a broadcom WLAN cards that Apple has used in there Mac's https://www.amazon.com/dp/B0156DVQ7G
 
Joined
Jan 22, 2018
macOS
10.13.3
Mobo
ASUS ROG Maximus X Hero
CPU
i7-8700k
GPU
AMD Radeon RX 560
#8
Hi Hackintosher! Finally got all my components together. Same mobo, same processor, however when trying to install (High Sierra 10.13.3) I am getting "MacOS could not be installed on your computer" error. Any idea what might be causing this?

I followed the BIOS settings recommendations and update the mobo firmware to 1003 but no luck yet :(

I have also tried some options mentioned here: High Sierra fix: "macOS could not be installed on your computer" - Hackintosher

Edit: disabled onboard wifi and bluetooth as I have not yet received my replacement card and restarted installation from scratch and that seems to have worked :D
 
Last edited:
Joined
Jan 22, 2018
macOS
10.13.3
Mobo
ASUS ROG Maximus X Hero
CPU
i7-8700k
GPU
AMD Radeon RX 560
#9
I have an issue with sleep not working. Don't have any USB devices plugged in except for a temporary bluetooth dongle. I've tried putting it to sleep without the USB attached but no luck. The system goes into full sleep mode, but then immediately wakes up again soon after. Used your EFI, double checked energy settings and darkwake mode but all seems to be in order. Any ideas of what else I can try?
 

Riku101

New member
Joined
Feb 20, 2018
Mobo
Asus Maximus IX Hero
CPU
Intel i7 7700K @ 5.1Ghz
GPU
Nvidia GTX 1080Ti
#10
Are theese config.plist files compatible with maximus IX hero, a kaby lake 7700k and a 1080 ti?
 
Joined
Feb 21, 2018
Mobo
Z370 Aorus Gaming 7
CPU
Intel Core i7 8700K
GPU
Aorus RX570 4G
#11
Great build! Congratulations! Thanks for the write up. I thought you were a Gigabyte fanboy after your initial Z370 build. BTW, how do you find the NZXT S340 case? Is it quiet? Cheers.
 

Hackintosher

Administrator
Joined
Jan 21, 2018
macOS
10.15.0
Mobo
Gigabyte Z370N WIFI
CPU
i3-8100
GPU
UHD 630 Graphics
#12
Great build! Congratulations! Thanks for the write up. I thought you were a Gigabyte fanboy after your initial Z370 build. BTW, how do you find the NZXT S340 case? Is it quiet? Cheers.
Yes it's quiet, of all the cases I've used these stock fans are the quietest. I can't hear the fans neither do they make that annoying clicking sound that some fans make.
 
Likes: PliSsK

Roen

New member
Joined
Feb 5, 2018
macOS
10.13.3
Mobo
ASUS ROG Strix Z370-I
CPU
i7-8700K
GPU
UHD630
#13
Z370-I Gaming
8700K
UHD 630
OS X 13.3
Broadcom / Dell Wifi/BT Card

Seems to work without issues.

Great guide!
 

Dandiccf

New member
Joined
Feb 28, 2018
macOS
10.13.3
Mobo
Asus Maximus X Formula
CPU
Intel i8700K
GPU
Asus Strix Nvidia 1080 TI OC
#14
Thx for your great guide.

I am just about to build my first Hackintosh (most likely almost your setup) and I am wondering why you did not include the "Emulated NVRAM" efi, which seem (as far as I read in other guides) to be mandatory for iMessage to work?

thx for your feedback.
 
Joined
Feb 27, 2018
macOS
10.13.3
Mobo
Asus ROG Maximus X Hero Wifi
CPU
Intel i7 8700K
GPU
Sapphire Radeon RX 580 Nitro+ 8GB
#15
I am installing my first hackintosh using your build list as a reference, the only difference is that I'm using a Sapphire RX 580 GPU, 2x Crucial Ballistix Sport 16gb 2400Mhz RAM modules and Corsair h115i water cooler, all the other components are exactly the same.

I am having trouble to complete the installation, first the installer wouldn't get past the progress bar after loading it in Clover (I just get a blank screen when the progress bar reaches the middle). I suspect this is to do with the Radeon GPU, so I disabled it in the BIOS and tried to install using the Intel integrated GPU (IGPX). This time I can complete the install, but after disabling AFPS and rebooting to complete the installation, the install progress bar is finished and all I get is a blank screen with the rainbow circle. I have tried this multiple times with the same results, I have set all the suggested BIOS settings before starting the install and I am using the stock EFI folder linked in the installation guide.

Any idea of what is going wrong, or any clues on how to troubleshoot the problem?

Thanks in advance!
 

Roen

New member
Joined
Feb 5, 2018
macOS
10.13.3
Mobo
ASUS ROG Strix Z370-I
CPU
i7-8700K
GPU
UHD630
#16
Thx for your great guide.

I am just about to build my first Hackintosh (most likely almost your setup) and I am wondering why you did not include the "Emulated NVRAM" efi, which seem (as far as I read in other guides) to be mandatory for iMessage to work?

thx for your feedback.
iMessage works for me without messing with Emulated NVRAM.
 
Joined
Feb 27, 2018
macOS
10.13.3
Mobo
Asus ROG Maximus X Hero Wifi
CPU
Intel i7 8700K
GPU
Sapphire Radeon RX 580 Nitro+ 8GB
#17
Another observation about this item in the BIOS settings:

6. Advanced \ AMP Configuration → Power On By PCI-E/PCI

It's not clear if that setting should be enabled or disabled.
 
Joined
Feb 27, 2018
macOS
10.13.3
Mobo
Asus ROG Maximus X Hero Wifi
CPU
Intel i7 8700K
GPU
Sapphire Radeon RX 580 Nitro+ 8GB
#18
I am installing my first hackintosh using your build list as a reference, the only difference is that I'm using a Sapphire RX 580 GPU, 2x Crucial Ballistix Sport 16gb 2400Mhz RAM modules and Corsair h115i water cooler, all the other components are exactly the same.

I am having trouble to complete the installation, first the installer wouldn't get past the progress bar after loading it in Clover (I just get a blank screen when the progress bar reaches the middle). I suspect this is to do with the Radeon GPU, so I disabled it in the BIOS and tried to install using the Intel integrated GPU (IGPX). This time I can complete the install, but after disabling AFPS and rebooting to complete the installation, the install progress bar is finished and all I get is a blank screen with the rainbow circle. I have tried this multiple times with the same results, I have set all the suggested BIOS settings before starting the install and I am using the stock EFI folder linked in the installation guide.

Any idea of what is going wrong, or any clues on how to troubleshoot the problem?

Thanks in advance!
I was finally able to complete the installation!
My problem was the display-port cable connected to the GPU, after I replaced it with a HDMI 2.0 cable everything completed without any errors.
I now have a fully capable hackintosh, including wifi and bluetooth after installing the DW1560 board.

Thank you!
 
Joined
Feb 27, 2018
macOS
10.13.3
Mobo
Asus ROG Maximus X Hero Wifi
CPU
Intel i7 8700K
GPU
Sapphire Radeon RX 580 Nitro+ 8GB
#19
Now there's one last thing to fix: when I put my computer to sleep it awakes right after entering sleep mode. Any clues?
 
Joined
Feb 27, 2018
macOS
10.13.3
Mobo
Asus ROG Maximus X Hero Wifi
CPU
Intel i7 8700K
GPU
Sapphire Radeon RX 580 Nitro+ 8GB
#20
After some more investigation, it happened to be the USB connector plugged to my Corsair h115i watercooler! Since there's no use for it on Mac OS X (their software only works on Windows) I unplugged it and voilà, now it sleeps properly :)