[Success][Guide] OpenCore Gigabyte Z490 Gaming X i7 10700 (Big Sur/Catalina)

Railgun

Well-known member
Joined
Jul 4, 2020
macOS
10.16.0
Mobo
GigaByte Z490 Gaming X
CPU
i7 10700
GPU
Sapphire RX580
After update EFI, i can see Windows partition on boot menu.

Also after update EFI you need to set startup disk, if you don't want to select macOS disk manually.
Thanks for the feedback.

After changing EFI folders I recommend rest NVRAM in the boot menu and once booted into macOS re-setting the start up disk in system preferences.
 
Last edited:

zarswow

New member
Joined
May 29, 2021
macOS
10.11.x
Mobo
Gigabyte Z490 Gaming X
CPU
10700K
GPU
5800XT
Hi Railgun,

I got a problem with the Big Sur 11.4, when I installing macOS Big Sur, about 15-16 minutes it would said「an error occurred loading the update」, and the Catalina 10.15.7 also said「installation cannot proceed because the installer is damaged」.

A lot of people said change the date in the terminal to the release date of the OS, but I found it could not work in my case.

Did I do something wrong? I have been working with this problem for three day, could you help me?
 

Railgun

Well-known member
Joined
Jul 4, 2020
macOS
10.16.0
Mobo
GigaByte Z490 Gaming X
CPU
i7 10700
GPU
Sapphire RX580
zafswow, are you installing over a WIFI connection? If so, try connecting with LAN line. This could solve the issue with Big Sur update. But I have not encountered that myself. Just what I have read online to use LAN connection.

For Catalina "installer is damaged" did you try the following from the guide?

** IMPORTANT NOTE FOR CATALINA: You may encounter an error within the installation process saying “this installation is damaged”, so it is best to fix this beforehand. You will need to delete Installinfo.plist file from the installer disk:
  • Open the “Install macOS Catalina” Disk (your thumb drive)
  • Right Click on the package “Install macOS Catalina”
  • Click on “Show Package Contents”
  • Go to Contents/SharedSupport folder
  • Delete the Installlnfo.plist file
 
Last edited:

zarswow

New member
Joined
May 29, 2021
macOS
10.11.x
Mobo
Gigabyte Z490 Gaming X
CPU
10700K
GPU
5800XT
zafswow, are you installing over a WIFI connection? If so, try connecting with LAN line. This could solve the issue with Big Sur update. But I have not encountered that myself. Just what I have read online to use LAN connection.

For Catalina "installer is damaged" did you try the following from the guide?

** IMPORTANT NOTE FOR CATALINA: You may encounter an error within the installation process saying “this installation is damaged”, so it is best to fix this beforehand. You will need to delete Installinfo.plist file from the installer disk:
  • Open the “Install macOS Catalina” Disk (your thumb drive)
  • Right Click on the package “Install macOS Catalina”
  • Click on “Show Package Contents”
  • Go to Contents/SharedSupport folder
  • Delete the Installlnfo.plist file
Quiet sorry for ignore that important tips, because my english is so poor. And I do delete that file in thumb drive, but soon I found that the installing program would switch from Recovery Mode to macOS Utilities, so I could not use the thumb drive installing the catalina, is that because of the deleting? and I tried the Big Sur EFI you upload friday, and use the iMac 19,1 SMBIOS, but it still entry the macOS Utilities, and I need to keep on line to download the installing files.

What shoul I do to return to recovery mode? Thanks for your reply, I'm so appreciated.
 

Railgun

Well-known member
Joined
Jul 4, 2020
macOS
10.16.0
Mobo
GigaByte Z490 Gaming X
CPU
i7 10700
GPU
Sapphire RX580
You removed the file and got past the "Damaged" message. That is good!

I will take it step by step here:
  1. You can just use iMac19,1 for SMBIOS in the config.plist file. This will allow you to boot both Big Sur and Catalina.
  2. Make sure you add a Serial Number, MLB and UUID in the file under platforminfo. Use GenSMBIOS and just copy past them into place and save the file. This will help when you boot as it connects to Apple to check the info.
  3. When you boot the installer a big window will come up for a few seconds says "macOS Recovery", then you will see the macOS Utilities window.
    DSC_4939.JPG
    DSC_4940.JPG
  4. Here you can click Disk Utility and make sure you format the destination drive (the drive you want to install the OS on) to APFS.
  5. After that quit Disk Utility and you should be back to macOS Utilities window (shown above).
  6. Now Click on Install macOS and follow the instructions.
  7. The installation will re-boot along the way... you may see "Macintosh" in the boot list when it dose and it should already be auto selected. Let it run.
  8. Let the installation finish and then it will boot into the internal drive and you will go through the setup stage and finally see the desktop.
After you are installed:
  1. Mount the EFI partition of the thumb drive and of the internal drive and copy the EFI folder from the thumb drives EFI partition to the internal EFI partition.
  2. Go to System Preferences and set the Startup Disk to your internal drive.
  3. Also in System Preferences go to Sound>Output and select Internal Speakers to make sure audio is working. This is for using the back of the motherboard green audio output.
  4. Restart and it should boot from the internal drive.
I hope this helps. :)
 
Last edited:

zarswow

New member
Joined
May 29, 2021
macOS
10.11.x
Mobo
Gigabyte Z490 Gaming X
CPU
10700K
GPU
5800XT
You removed the file and got past the "Damaged" message. That is good!

I will take it step by step here:
  1. You can just use iMac19,1 for SMBIOS in the config.plist file. This will allow you to boot both Big Sur and Catalina.
  2. Make sure you add a Serial Number, MLB and UUID in the file under platforminfo. Use GenSMBIOS and just copy past them into place and save the file. This will help when you boot as it connects to Apple to check the info.
  3. When you boot the installer a big window will come up for a few seconds says "macOS Recovery", then you will see the macOS Utilities window. View attachment 11552 View attachment 11553
  4. Here you can click Disk Utility and make sure you format the destination drive (the drive you want to install the OS on) to APFS.
  5. After that quit Disk Utility and you should be back to macOS Utilities window (shown above).
  6. Now Click on Install macOS and follow the instructions.
  7. The installation will re-boot along the way... you may see "Macintosh" in the boot list when it dose and it should already be auto selected. Let it run.
  8. Let the installation finish and then it will boot into the internal drive and you will go through the setup stage and finally see the desktop.
After you are installed:
  1. Mount the EFI partition of the thumb drive and of the internal drive and copy the EFI folder from the thumb drives EFI partition to the internal EFI partition.
  2. Go to System Preferences and set the Startup Disk to your internal drive.
  3. Also in System Preferences go to Sound>Output and select Internal Speakers to make sure audio is working. This is for using the back of the motherboard green audio output.
  4. Restart and it should boot from the internal drive.
I hope this helps. :)
Sorry for wasting your time, and appreciated for your reply.

I do follow the steps and what bother me is the installing program ask me to link the internet otherwise it wouldn't let me go further, but if I connect to internet with the cable and wifi, the installing program wants to download the InstallESDDmg.pkg from http://swcdn.apple.com, but I don't know why, it just couldn't complete downloading from the site, and after 4 times retry, it come back with the 「The operation couldn’t be completed. (PKDownloadError error 8.)」, then send me back to the beginning.

but I pasted the download link in the catlog with my MacBook, finding the InstallESDDmg.pkg could be download very smoothly in my internet environment.

I have try to install the hackintosh in the past five days(can't believe in the five days I just made so much mistakes and couldn't make it success, I'm almost crazy within it), all the installers were offline and didn't have to connect the internet, so I doubt if is I delete the Installlnfo.plist so the installer ask me to online install.

Or somewhere I did it wrong but I just don't know where. Please help!
 

zarswow

New member
Joined
May 29, 2021
macOS
10.11.x
Mobo
Gigabyte Z490 Gaming X
CPU
10700K
GPU
5800XT
I checked it, if I keep Installlnfo.plist, it will start install the macOS offline; but if I delete the Installlnfo.plist, it will force me install macOS on line and download InstallESDDmg.pkg from http://swcdn.apple.com, even I use the OC6.9 EFI you upload Friday and fill the iMac 19,1 SMBIOS and mb data.

I upload the EFI I modified, please have a look.
 

Attachments

zarswow

New member
Joined
May 29, 2021
macOS
10.11.x
Mobo
Gigabyte Z490 Gaming X
CPU
10700K
GPU
5800XT
For Big Sur, I also face a problem that the installer log shows sharedsupport.dmg "pkgdmg checksum does not match,possible corruption", but I checked the md5 found the sharedsupport.dmg in Thumb Drive match the one in the Installer, and the Installer's md5 match the the Installer in the internet, and the internet's Installer can't be damaged, so I don't understand how could this happen.

This is the installer log:

Code:
May 30 07:46:56 iMac osinstallersetupd[278]: Mount point /Volumes/Shared Support
May 30 07:46:56 iMac osinstallersetupd[278]: Using product <OSISCollectionInstallProduct: 0x7fb9030070f0> at distance 10
May 30 07:46:56 iMac osinstallersetupd[278]: Helper tool loaded
May 30 07:46:56 iMac osinstallersetupd[278]: : 00519000 : Failed to create systemVersionDict
May 30 07:46:56 iMac osinstallersetupd[278]: : 00519000 : Failed to get currentInstalledBuild. Assuming clean install
May 30 07:46:56 iMac osinstallersetupd[278]: : 00519000 : Failed to create systemVersionDict
May 30 07:46:56 iMac osinstallersetupd[278]: : 00519000 : Failed to get currentInstalledBuild
May 30 07:46:57 iMac osinstallersetupd[278]: Verify calculated time estimate: 1186.036643 for /System/Volumes/Data/private/var/folders/zz/zyxvpxvq6csfxvn_n0000000000000/Cleanup At Startup/IA.M0Cap/Install macOS Big Sur.app/Contents/SharedSupport/SharedSupport.dmg
May 30 07:46:57 iMac osinstallersetupd[278]: Required package references: (
    )
May 30 07:46:57 iMac osishelperd[284]: Privileged helper tool loaded.
May 30 07:46:57 iMac osinstallersetupd[278]: Skipping bridgeOS update because the current hardware doesn't support bridgeOS
May 30 07:46:57 iMac osinstallersetupd[278]: Operation queue started
May 30 07:46:57 iMac osinstallersetupd[278]: Getting offset for dmg in pkg: /System/Volumes/Data/private/var/folders/zz/zyxvpxvq6csfxvn_n0000000000000/Cleanup At Startup/IA.M0Cap/Install macOS Big Sur.app/Contents/SharedSupport/SharedSupport.dmg
May 30 07:46:57 iMac osinstallersetupd[278]: Verifying SharedSupport.dmg
May 30 07:49:08 iMac osinstallersetupd[278]: pkgdmg checksum does not match, possible corruption.
May 30 07:49:08 iMac osinstallersetupd[278]: pkgdmg validation has failed.
May 30 07:49:08 iMac osinstallersetupd[278]: Operation queue failed with error: Error Domain=com.apple.OSInstallerSetup.error Code=255 "Installation cannot proceed because the installer is damaged." UserInfo={NSLocalizedDescription=Installation cannot proceed because the installer is damaged., NSLocalizedRecoverySuggestion=Redownload the installer and try again.}
 

Railgun

Well-known member
Joined
Jul 4, 2020
macOS
10.16.0
Mobo
GigaByte Z490 Gaming X
CPU
i7 10700
GPU
Sapphire RX580
Remove Installlnfo.plist is only for Catalina and only if it gives you "damaged" message. If not, then install it online or offline is OK.

Big Sur...
Where did you download the installer app from? You should get it from the Apple App Store (Do not use gibMacOS for Big Sur).
 
Last edited:

zarswow

New member
Joined
May 29, 2021
macOS
10.11.x
Mobo
Gigabyte Z490 Gaming X
CPU
10700K
GPU
5800XT
Remove Installlnfo.plist is only for Catalina and only if it gives you "damaged" message. If not, then install it offline is OK.

Big Sur...
Where did you download the installer app from? You should get it from the Apple App Store (Do not use gibMacOS for Big Sur).
So if I remove installInfo.plist it does will install Catalina on line? And it do will download the pkg files from swcdn.apple.com?

Big Sur I have gave it up, I want to figure out how could I install Catalina first haha……
 

Railgun

Well-known member
Joined
Jul 4, 2020
macOS
10.16.0
Mobo
GigaByte Z490 Gaming X
CPU
i7 10700
GPU
Sapphire RX580
I just re-installed Catalina 10.15.5 two weeks ago myself... it needed to connect online. I did not see it download anything, but it did and when finished it was 10.15.7.
 

zarswow

New member
Joined
May 29, 2021
macOS
10.11.x
Mobo
Gigabyte Z490 Gaming X
CPU
10700K
GPU
5800XT
I just re-installed Catalina 10.15.5 two weeks ago myself... it needed to connect online. I did not see it download anything, but it did and when finished it was 10.15.7.
Something must happened to my hardware, I replaced the motherboard of Gigabyte with the motherboard of ASUS, and still reported the error repeatedly, whether it was in Catalina or Big Sur. Finally, in desperation, I paid someone to go online to restore the Catalina, and then upgraded to Big Sur. The process was still twists and turns, the only luck was that the installation was successful finally, even though I replaced the motherboard, memory, and graphics card.

I don’t know if someone will encounter a situation similar to mine later. If so, you are not alone. Please check if your graphics card and memory are compatible.

Thank you for your patient reply before, Railgun!
 

Railgun

Well-known member
Joined
Jul 4, 2020
macOS
10.16.0
Mobo
GigaByte Z490 Gaming X
CPU
i7 10700
GPU
Sapphire RX580
It should have been a vey straight forward installation providing a new build, however if you have a hardware or connectivity issue I can not help from here. Since you had the same issue with ASUS, I can only say that something in the setup or process was wrong.
 
Likes: Edhawk

Railgun

Well-known member
Joined
Jul 4, 2020
macOS
10.16.0
Mobo
GigaByte Z490 Gaming X
CPU
i7 10700
GPU
Sapphire RX580
Update EFI to OpenCore 0.7.0

Attached to the main guide is a new file for OpenCore v0.7.0. Remember to edit the config.plist and add your platform info. I use iMac20,1 for SMBIOS. If your making a Catalina installer you must change it and use iMac19,1 (just for the installer).

(NEW) Included In My EFI Files:
  • OpenCanopy (GUI, no audio) Theme is set to Acidanthera\Chardonnay if you want to change it or add audio see the official guide: https://dortania.github.io/OpenCore-Post-Install/cosmetic/gui.html
  • CrScreenshotDxe.efi (driver) allows for screen grab in the boot loader (press F10). Screen grabs are saved to the EFI partition.
  • SMCProcessor.kext and SMCSuperIO.kext which allow for various hardware monitoring. I use iStatMenu app (paid app), alternately HWMonitor (free app).

Official OpenCore Release Notes: https://github.com/acidanthera/OpenCorePkg/releases