[Success][Guide] OpenCore Gigabyte Z490 Gaming X i7 10700 (Monterey/Big Sur/Catalina)

DashX

New member
Joined
Jul 4, 2021
Mobo
Z490 Gaming X
CPU
i9-10900
GPU
RX 6800
Hello DashX, and thanks for posting. I see you are using an Core i9 10900. So yes you will need to us the iMac20,2 SMBIOS per the OpenCore guide. I will be updating the main guide soon and include that info.

The Z490 X dose not have wifi.... Are you adding wifi or using a Z490 variant with swapped out wifi chip (Z490M)? The issue may have to do with a bios setting or which slot on the motherboard is being used.
Im added WiFi via PCIE Adapter. Both issue was resolved when i use IMAC20,2 SMBIOS.

Thanks for the awesome guide btw.
 
Likes: Railgun

Railgun

Well-known member
Joined
Jul 4, 2020
macOS
10.16.0
Mobo
GigaByte Z490 Gaming X
CPU
i7 10700
GPU
Sapphire RX580
I finally replaced my 23" Samsung monitor today. What a difference!...

LG 27QN600.jpeg


I purchased this LG 27" QN600 IPS 1440p. Looks better in person than this photo.

Great budget monitor for $230USD. The resolution is great, 1440p on 27" is the right spot and 99%sRGB. I am using the DP port from my RX580 set to 75Hertz, but I do turn off HDR (as HDR contrast is a bit much). The stand is stiff and sturdy and a little taller than I was expecting. Text is nice and crisp.

So far HAPPY with it (y)
 
Last edited:

Railgun

Well-known member
Joined
Jul 4, 2020
macOS
10.16.0
Mobo
GigaByte Z490 Gaming X
CPU
i7 10700
GPU
Sapphire RX580
Updated to OpenCore v0.7.1 (download new attached EFI from first post).

OpenCore 0.7.1 Release Notes: https://github.com/acidanthera/OpenCorePkg/releases

My EFI release notes:
  1. All the kext have been updated to latest releases.
  2. New USBPorts.kext (port mapping breaks from OC 070 to OC 071).
  3. Remember to edit the config.plist and put in your own MLB, SystemSerialNumber and SystemUUID under platforminfo. Use iMac20,1 for Big Sur/Catalina/Monterey Public Beta. If you are using the EFI for a Catalina installer, you must change it to iMac19,1. If you have an Intel Core i9 10900 use iMac20,2.
 
Likes: lifteri

Railgun

Well-known member
Joined
Jul 4, 2020
macOS
10.16.0
Mobo
GigaByte Z490 Gaming X
CPU
i7 10700
GPU
Sapphire RX580
A Note On How To Update macOS Monterey Public Beta

Screen Shot 2021-07-19 at 7.20.45 PM.png

As with the initial installing of macOS Monterey Beta, SecureBootMode needs to be set to Disabled in the OpenCore config.plist file. Do this and reboot before you download and install updates. As of this writing Monterey Public beta is at Beta 3 (see image above note the build number).

How too:
  1. Open the config.plist file, do a command find for SecureBootMode and change it too Disabled. then save the file.
  2. Re-boot, reset NVRAM in the OpenCore boot loader. It will reboot after that.
  3. Then boot into macOS Monterey, go to System Preferences>Software Update and then check for, download and install the update.
  4. After the update is fully installed you can change SecureBootMode back to Default.
 

Railgun

Well-known member
Joined
Jul 4, 2020
macOS
10.16.0
Mobo
GigaByte Z490 Gaming X
CPU
i7 10700
GPU
Sapphire RX580
Working on OpenCore 0.7.2 update... works fine except OpenCanopy is not showing. I have checked my 071 version and I don't think I am missing anything.

No update to OpenCanopy guide that would note a change.
 

Railgun

Well-known member
Joined
Jul 4, 2020
macOS
10.16.0
Mobo
GigaByte Z490 Gaming X
CPU
i7 10700
GPU
Sapphire RX580
Updated to OpenCore v0.7.2 (download new attached EFI from first post).

OpenCore 0.7.2 Release Notes: https://github.com/acidanthera/OpenCorePkg/releases

My EFI release notes:
  1. All the kext have been updated to latest releases.
  2. USBPorts.kext (port mapping) holds.
  3. Updated OpenCanopy Resources. Theme is set to Acidanthera\Chardonnay.
  4. Edit the config.plist and put in your own MLB, SystemSerialNumber and SystemUUID under platforminfo. Use iMac20,1 for Big Sur/Catalina/Monterey Public Beta.
  5. Intel Core i9 10900 use iMac20,2 SMBIOS.
If you are creating a Catalina Installer (thumb drive): If you have Catalina already installed you should be OK without this.
  1. Change the SMBIOS to iMac19,1 under platforminfo section and use appropriate MLB, SN and UUID.
  2. NEW - You need to change Misc -> Security -> SecureBootModel -> to Disabled otherwise it will not boot (tested).
 
Last edited:

Railgun

Well-known member
Joined
Jul 4, 2020
macOS
10.16.0
Mobo
GigaByte Z490 Gaming X
CPU
i7 10700
GPU
Sapphire RX580
Thanks John, was busy today but just updated. USB Port mapping holds.

Screen Shot 2021-08-11 at 5.52.58 PM.png
 
Likes: lifteri

Iwai

New member
Joined
Aug 12, 2021
macOS
10.15.7
Thanks John, was busy today but just updated. USB Port mapping holds.

View attachment 12058
Thanks for sharing your EFI and installation guide! However, when I started trying to migrate from my EFI settings to yours today, in open core start menu I could not find my nvme drive where my mac os system has already been installed. My nvme drive is western data SN750, which could be found in my previous EFI settings. Can you help me trouble shooting this problem?
 

Railgun

Well-known member
Joined
Jul 4, 2020
macOS
10.16.0
Mobo
GigaByte Z490 Gaming X
CPU
i7 10700
GPU
Sapphire RX580
Iwai, do you see it if you re-try your previous EFI?

What is your build specs and are you on Catalina? You can upload a zip file of your EFI (the whole folder) and will take a look at the differences.
 

Railgun

Well-known member
Joined
Jul 4, 2020
macOS
10.16.0
Mobo
GigaByte Z490 Gaming X
CPU
i7 10700
GPU
Sapphire RX580
OpenCore v0.7.3 is out... Updated files from my build will be a delay as there seems to be some issues.
  • AppleALC is updated. However Audio is not working at the moment which means there is some change. FIXED with proper kext file.
  • Issues with OpenCanopy even though I downloaded resources from latest linked Github.
  • ProperTree has been updated but there maybe issues. Also the previous version removes new UEFI driver arguments (if used to edit 073 config file).

Will have to wait on this one.
 
Last edited:

Railgun

Well-known member
Joined
Jul 4, 2020
macOS
10.16.0
Mobo
GigaByte Z490 Gaming X
CPU
i7 10700
GPU
Sapphire RX580
Updated to OpenCore v0.7.3 (download new attached EFI from first post).

OpenCore 0.7.3 Release Notes: https://github.com/acidanthera/OpenCorePkg/releases

***IMPORTANT NOTES FOR OC 073***
  • Use the latest version of ProperTree only and be aware as I have had issues this time around with editing config files using it. If you only need to add your SMBIOS info it can be done in TextEdit under platforminfo.
  • I have generated iMac20,1 SMBIOS info in place in order for this version to work. You should edit/replace the info with your own. Unlike in the past, it will not boot with placeholder text such as "MLB HERE" nor generic numbers such as in the OC distro sample.plist file.
  • Make sure you backup your existing working EFI folder. Or better still test the new EFI by booting from it off a thumb drive. Especially if you have a need to edit the config file or contents of the OC folder.

My EFI release notes:
  1. All the kext have been updated to the latest releases.
  2. USBPorts.kext (port mapping) holds.
  3. Updated OpenCanopy Resources. Theme is set to Acidanthera\Chardonnay.
  4. Edit the config.plist and put in your own MLB, SystemSerialNumber and SystemUUID under platforminfo. Use iMac20,1 for Big Sur/Catalina/Monterey Public Beta.
  5. Intel Core i9 10900 use iMac20,2 SMBIOS.


* Catalina - I no longer test for macOS Catalina however as noted before, if you are creating a Catalina Installer (thumb drive): If you have Catalina already installed you should be OK without this.
  1. Change the SMBIOS to iMac19,1 under platforminfo section and use appropriate MLB, SN and UUID.
  2. You need to change Misc -> Security -> SecureBootModel -> to Disabled otherwise it will not boot (tested).
 
Joined
Oct 18, 2020
Mobo
Gigabyte Z490 Gaming X
CPU
Intel Core i7 10700K
GPU
Sapphire Nitro+ RX580 8GB Special Edition
Railgun
Thank you for the EFI folder its great and everything works as it should on my i7 10700K :)
btw reguarding the opencore theme anychance you can change it to the new Acidanthera\GoldenGate one

i tried to do it myself it didnt work :(
Screen Shot 2021-08-20 at 10.27.40 AM.png
 
Likes: Railgun

Railgun

Well-known member
Joined
Jul 4, 2020
macOS
10.16.0
Mobo
GigaByte Z490 Gaming X
CPU
i7 10700
GPU
Sapphire RX580
imatrix83, This is where I had issues with 073 Themes. My custom theme worked fine but as soon as I changed it, the EFI would not boot. I am not sure if it is OC or PropperTree (I think it is the later). Anyway I just tested GoldenGate... I edited the path in TextEdit App instead of PropperTree. Attached below is the same EFI with that change (GoldenGate Theme).

10190354.png
 

Attachments

Last edited:
Joined
Apr 10, 2018
macOS
10.15.7
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
Powercolor RX 580 8GB
Look under Misc > Boot > PickerVariant - usually says Auto by default.

If you want to change it to one of Acidanthera's themes you need to replace Auto with your selection such as Acidanthera/GoldenGate or Acidanthera/Chardonnay or Acidanthera/Syrah.

If you add a new folder to the Resources Image folder that sits along side the Acidanthera folder, i.e. a folder called Themes. Then you need to set PickerVariant to Themes/NameofTheme as above.

Watch which way the slash is pointing, it should be a forward slash / not a backwards slash \ between Acidanthera and the theme name. Notice also no spaces between the words.
 
Joined
Apr 10, 2018
macOS
10.15.7
Mobo
GA-Z97X-UD5H
CPU
i7-4790K
GPU
Powercolor RX 580 8GB
Well I got that completely wrong, Doh!

It is a Back slash not a forward slash that separates the folder and theme names.
  • Auto — Automatically select one set of icons based on DefaultBackground colour.
  • Acidanthera\Syrah — Normal icon set.
  • Acidanthera\GoldenGate — Nouveau icon set.
  • Acidanthera\Chardonnay — Vintage icon set.