Would somebody please patch a frame buffer for me? (Mojave)

Joined
Nov 8, 2018
macOS
10.13.6
Mobo
Z370 K6 Gaming
CPU
i7-8700k
GPU
UHD630
#1
Hello,

I would like to update my High Sierra to Mojave but last time I had many problems with my eGPU (UHD630) so I decided to back to the HS. Everything works fine but I would like to have, if possible, the latest version of macOS. Unfortunately I completely cannot understand how to patch frame buffer that is needed to get working integrated GPU. In this case I would like to ask you, would somebody do it for me? Thank you.
 

Attachments

Joined
Nov 8, 2018
macOS
Mobo
HP IPM17-0D
CPU
i7-6700
GPU
Intel HD 530
#2

Attachments

Likes: davede
Joined
Nov 8, 2018
macOS
10.13.6
Mobo
Z370 K6 Gaming
CPU
i7-8700k
GPU
UHD630
#3
Wow, thank you for your great work. I will try it when I will be at home and provide a feedback.
 
Joined
Nov 8, 2018
macOS
10.13.6
Mobo
Z370 K6 Gaming
CPU
i7-8700k
GPU
UHD630
#4
Do I have to do something extra after that? Because I replaced my config.plist and after update to Mojave, whole of my screen is purple/pink and I am not sure but This Mac shows UHD630 with 2GB of VRAM, but I think it should be 1,5GB. I didn't find anything about purple screen in your recommended thread. :eek:
 
Joined
Nov 8, 2018
macOS
10.13.6
Mobo
Z370 K6 Gaming
CPU
i7-8700k
GPU
UHD630
#6
Wow, you are truly God of Hackintosh. The new config just helped me and I didn't have to force rgb mode because the problem just gone. Looks like everything works fine. Thanks!!!!
 
Likes: jo_ko_0