Z390 audio build - NVRAM/iMessage help

lettucehat

New member
Joined
Jul 5, 2020
macOS
10.15.4
Mobo
Z390 Designare
CPU
i9-9900K
GPU
MSI RX 570
#1
Hi everybody!

I’ve been using my Hackintosh almost without any issues for about a month or two, with the last month or so involving heavy use of Logic, big sessions with large sample library templates. Except for a couple problems I’ll mention later, no issues. Sleep always worked beautifully.

I used Clover and mostly followed the guide of Youtuber Technolli. I originally had issues following his guide because my BIOS was a different version from his but after that it was smooth sailing.

My main issue is that iMessage never seemed to work, but I didn’t care much, but I’m trying again. App Store always worked just fine. I started following an iMessage guide on another forum and it led me to realize that NVRAM is really the current problem. I've done the NVRAM tests, doesn't work. Now I see the 300 series generally have a major issue with this, but none of the fixes seem to help me personally.

First I tried NVRAM emulation (Aptio, Emuvariableuefi) and they either did nothing or caused major problems. Similar issues as when I first installed, as I was back then trying to make boot loader themes work (I gave up):

  • AptioMemoryFix is the one that didn’t work, I think
  • Emuvariableuefi led to a Ø black screen, thankfully I had a USB drive I could boot from and revert to a previous config.plist
  • I can’t remember the order of events, but losing USB at the logic screen would take place - sometimes it started working after waiting a while, but it seems the only long term fix is keeping the harmful “OsxAptioFix2Drv-free2000.efi” in the drivers folder - the strange thing is, it’s just in there, but it’s not even an option in Clover Configurator..? Keep in mind I used Technolli’s files, I guess this is why it’s there.


So I’m back to where I started. I think I never installed “RC scripts” so that may be why Emuvariableuefi failed? But I don’t know how to install them without messing with Clover.

It’s ok though! I think I should skip NVRAM emulation because of this newer development:

https://www.reddit.com/r/hackintosh/comments/erd2th/nvram_for_all_300_series_users_rejoice/

However, placing this precompiled .aml file in my patched folder doesn’t work either. This thread introduced me to a lot of new things I don’t really understand. I definitely do not have of the emulation files so that’s not the problem. I see this “it requires LPCB in your DSDT” but all of this MaciASL / iasl stuff fails for me too (errors with the first, can’t place iasl in usr/bin either). I have no idea how to check if there’s “LPCB” in my “DSDT” lol. Is there anything I can do in Clover? Why does this seem to work for other Z390 users?


So that’s my main issue. But this whole process has shown me a few new things and I’m wondering if they are somehow related, at least the USB/memory related ones. Here’s a quick list of the other issues I’ve been having, lower priority than NVRAM but would be nice to figure out:

  • USB ports at the front of case have been inconsistent, sometimes not working (haven’t tested speeds)
  • When running an intense Logic session, I’ve a problem where the keyboard/mouse seem to die and the session simply keeps playing (so not a crash exactly) - unplugging/re-plugging doesn’t work, I have to restart the whole machine.
  • I’m now paranoid about “OsxAptioFix2Drv-free2000.efi”, but don’t understand it, I just want to make sure that anything memory related isn’t causing harm to my hardware… and now I wonder if my high-RAM usage sessions are causing USB problems and it’s connected to this driver I didn’t even personally install…? I’m only keeping it because otherwise USB seems to die.
  • “About This Mac” displays RAM speed as 2133 MHz not 2400 - this speed is already kinda slow, is this just misreporting or is my RAM operating slower?
  • “About This Mac” displays GPU as RX 580 when it’s actually 570. No graphics problems, just noticed this one actually! (I believe this is because I used Technolli's files and he uses some kind of file that's designed for 580 but it's worked for me regardless

Sorry for all the typing, but I can see this is a really friendly and helpful community so I put everything there instead of just pretending it’s only one problem! Hope all the information is helpful rather than overkill.


PS:

https://www.tonymacx86.com/threads/gigabyte-z390-m-gaming-build-with-working-nvram.291193/

This guy got NVRAM working using MSR, which I didn’t even hear about from the other threads showing the native NVRAM fix working for so many people. Is this necessary?