How to get Z390 motherboards working on a Hackintosh

With the 10th generation of Intel processors and motherboards on the horizon its getting pretty hard to find a decent Z370 motherboard that isn’t out of stock or overpriced leftovers by third party vendors. While the Z390 chipset doesn’t have native nvram support it still can be configured to run smooth in macOS Catalina or even Mojave if a little extra steps and are taken.

Z390 Hackintosh Notes

  • Recommended to install macOS over Display Port when Intel UHD 630 Graphics is used as the primary display driver without a discrete graphics card.
    • This is because the HDMI port included with certain Z390 motherboards may boot only to show a black screen this can be fixed later by mapping the HDMI port.
  • When Intel UHD 630 Graphics is used without a discrete graphics card adding a AAPL,ig-platform-id patch in config.plist will cause a couple seconds of lag on boot + system wake removing the patch removes the lag, but if you are depending on WhateverGreen.kext for patching you may need it.
  • When Intel UHD 630 Graphics is used without a discrete graphics card there is an issue with HDMI/DP audio causing a kernel panic when the system is waked up. Problem only happens on Catalina, fixed by disabling HDMI audio with No-hda-gfx in config.plist
  • Certain motherboards require a RTC patch to get past a AppleEPC…. error on boot.
  • Without native NVRAM support Z390 motherboards require EmuVariableUefi placed in the drivers folder of the EFI folder.
  • slide=0 is not a requirement but can be useful.
  • Catalina has 9th generation Intel CPU support, if you are attempting to install an earlier version of Mojave instead of Catalina adding a device-id patch may be needed.
  •  Do not use OsxAptioFix2Drv-free2000, I’ve been able to boot Catalina on a Z390 build with any of these: FwRuntimeServices.efi + OcQuirks.efi, AptioMemoryFix, OsxAptioFix3Drv, OsxAptioFix2Drv.
  • Add slide=0 as a bootflag in config.plist under Boot -> Boot Arguments or in the Clover Boot Menu if you experience any freezes or crashes.
  • If you need a preconfigured EFI folder to drop in and work with: from Catalina Hackintosh Install Guide
    • All I did was enable an EC0 to EC patch, add slide=0 as a boot flag and add the BIOS patch for my ASUS Z390-A motherboard and it work.
    • Dont forget to place it in the EFI partition ofc.

1.  Z390 Required EFI Drivers

Minimum in Drivers UEFI folder

This is what I use at minimum with Z390 in my drivers folder EFI/Clover/drivers/UEFI/. Notice I have FwRunetimeServices.efi and OcQuirks.efi. This is my preferred method memory driver since support was ended for AptioMemoryFix.efi in Clover as the developer shifted over to OpenCore. OcQuirks.efi ports back the updates back into and it’s dependent upon FwRunetimeServices.efi so they must be together in the drivers/UEFI/ folder.

There are other memory driver options that work in macOS Catalina/Mojave I’ve tested. Use FwRuntimeServices.efi + OcQuirks.efi to start with if you have any issues you can try driver fixes in this order, AptioMemoryFix, OsxAptioFix3Drv, OsxAptioFix2Drv. All of these options worked with my ASUS Z390-A motherboard.

Make sure to use your memory driver(s) with EmuVariableUefi.efi which should be located in the same folder as Z390 doesn’t have native NVRAM support.

Use slide=0 as as a boot flag to avoid any random freezes when using macOS on the Z390 platform.

1.1 Extra step for Gigabyte Z390 motherboards Error allocating runtime area

The only memory drivers that work with Gigabyte Z390 motherboards are QcQuirks.efi/FwRunetimeServices.efi and OsxAptioFix2Drv-free2000.efi. Most people end up using OsxAptioFix2Drv-free2000.efi but you really should avoid it if possible see: Developers warning.

Gigabyte Z390 Memory Error Verbose

Without a working memory driver this error will appear on a Gigabyte Z390 motherboard.

The better way is with OcQuirks.efi + FwRunetimeServices.efi, but to get these drivers working on Gigabyte motherboards it also requires DevirtualiseMmio set true and ForceExitBootServices set false. These values can be set by either building OcQuirks in XCode with these values or editing a supplementary OcQuirks.plist with TextEdit and placing it in the same drivers folder as OcQuirks.efi.

  • Download & Unzip the latest version of OcQuirks.efi from the RELEASE page.
  • Paste QcQuirks.efi, FwRunetimeServices.efi and OcQuirks.plist to /Volumes/EFI/EFI/CLOVER/drivers/UEFI/
  • Open  OcQuirks.plist with TextEdit by Right-clicking OcQuirks.plist -> Open With -> Other… -> Text Edit
  • Change the value under DevirtualiseMmio to true
  • Change the value under ForceExitBootServices to false
  • Save & Exit
  • Delete nvram.plist if it exists in /Volumes/EFI/ (otherwise the fix wont work): nvram.plist delete hackintosh


EC Patch needed for Catalina

Changes in Catalina require the EC to be renamed/faked to work. If you’re going with the rename method its most likely going to be the EC0 to EC patch with Z390.

EC Patching – Dealing with AppleACPIEC on a Catalina Hackintosh

3. BIOS Patch for Z390 ASUS/ASRock Motherboards

Missing BIOS Patch

Certain ASUS and ASRock motherboards need a RTC BIOS patch to get past the loader hanging on an error.

This patch goes under Apci -> Fixes in config.plist

Comment Find* [HEX] Replace [HEX]
Z390/Z370 II BIOS RTC Patch A00A9353 54415301 A00A910A FF0BFFFF

RTC BIOS FIX Z390 Hackintosh

4. Z390 HDMI port black screen fix

The HDMI port(s) included on the motherboard might not work without being patched on a Z390 motherboard and will boot to a black screen. It’s recommended to install macOS over displayport until a patch is added to map the Bus ID of each port correctly.

To map the HDMI/DP ports properly use Hackintool. This is a time consuming process trying to match the correct ports but it can be done with some patients. There are there are various guides on the web such as this one here.

If you have Xcode installed you can build the latest version of Hackintool here


Guide to fresh installing macOS Catalina on a Hackintosh (10.15 Update)

ASUS PRIME Z390-A Hackintosh Build Guide w/ RX 5700 XT

GIGABYTE Z390 AORUS Ultra i7-9700k Vega 64 Hackintosh Build Guide

Leave a Reply

36 Comments on "How to get Z390 motherboards working on a Hackintosh"

Sort by:   newest | oldest

why shouldn’t OsxAptioFix2Drv-free2000 be used?
It’s the only memory fixes that work with my Gigabyte Z390 ultra. I’ve tried your EFI file. unfortunately, none of the configurations worked on my Z390 ultra.


It was accidentally released and never intended for extended use as it can let some things go unregulated and cause actual hardware damage. This post is good but leaves out the fact that you can use emuvariable and a calculated slide value to get your nvram working as well. Many people use free2000 to get them through the installer if nothing else works, but then you need to run memmap and calculate a slide value to add to your boot arguments, and get rid of free2000 asap. I’m using a msi z390 board. Works great booting with emuvariable efi And slide=128 your slide value will most likely be different. Range is 0-256. Theres a formula you need to run hex values thru from memmap, then run it backwards and if you come out with a different hex value, then add 1 to your slide value. For me it was 127 + 1 to get 128

Juan Martin Ruiz

After reading the link I’ve discovered, if I set the internal graphics card to auto or disable.The FwRunetimeServices.efi and QcQuirks.ef works. The downside I can’t use Hardware Acceleration

Michael g
Michael g

I had this same error (Couldn’t allocate runtime area) with Z390 Aorus Pro Wifi Mini-ITX and dGPU RX580 4gb. I turned off internal graphics and it fixed the problem. Still using AptioMemoryFix-64.efi and going fine.



Any chance over the weekend of a tutorial on how to compile an OcQuirks, using Xcode?



Thank you so so so much, dear Hackintosher! 😀
Your website got me started on “hackintoshing” last year and now this article keeps me going…

I run 10.13.6 High Sierra (17G12034) on a Gigabyte Z390 I AORUS PRO mobo with i3-8100, 16 GB RAM and GTX 1060.
I had some issues with the “couldn’t allocate runtime area” errors for a couple of days now. I tried all of the drivers with disappointing results. AptioMemoryFix.efi only works with iGPU turned off in BIOS as already stated in the comments. And I try to avoid OsxAptioFix2Drv-free2000.efi for the very same reasons you already discussed.

Your “extra step” helped me solve the issue and keep hardware acceleration for iGPU and dGPU! Thanks again.



Hoping I could get some help, I’m getting hung up in the boot from USB stage.

My Build includes:
Catalina onto
ASRock Z390 Phantom Gaming ITX [bios 4.40]
i5 9400

Here’s my EFI folder:


THANK YOU! I was finally able to get the installer to boot, but I have an error for disk25s1 is not convertible to APFS: You may not install on this volume…

Even tried a different NVMe drive but no luck


Thanks for this good Tutorial.
I’ll try this on this machine:
Intel i5 9600K
Bios v. 1401


I am a super newbie to the Hackintosh world. The board I am using for my build is the gigabyte z390 designare. Is it possible to get the onboard audio card to work specifically the Spidif Optical out. Thanks in advance any help is appreciated this thing has been driving me crazy for the pass 3 days.

Specs for my build:
Gigabyte z390 designare

Intel Core i9 9900K

Radeon RX 570

The SMBIOS is setup to an iMac Pro 2017


Personally I would use opencore. Easy to follow tutorials

OPENCORE CATALINA Z390 Gigabyte Designare Hackintosh


I have Gigabyte Z390I Aorus Wifi pro and 10.15.4 my problem is very weird and can not fix it.

I have broadcom bt adapter and connecting via pciex card. Wifi works only if i set bifurction mode in Bios different from 16x. But sometimes without any special reason i am getting kps. İn these time i have to change bifurction to 16x boot up and go bios and change the value 8×8

İt is really annoying. What can be reason


Hi Everyone,
I’m brand new to hackintosh, i tried to save money on buying a mac and now im suffering because of it.
I got this set up: z390UD, i5-9600kf, RX580GTS 8GB, 2x8gb ramm, 240gb nvme.
I’ve followed countless youtube videos, loads of pages on here on how to install it but I’m just not able to do this. Im now considering installing windows as im stuck, but i really dont want to,
Does anybody have the EFI folder set up for the set up above? or can someone please help me make one?
any advice you can give me would be amazing as my brain has melted several times over the past week of trying 🙁