Hackintosh HDMI Audio + DisplayPort GFX Card Sound Guide

If your display has sound and you want monitor audio thru HDMI or DisplayPort  you can follow these steps if you have a dedicated graphics card. This guide is assuming your using a Clover EFI learn how to make one with the Clover EFI Bootloader Guide. If you are using integrated graphics see: Hackintosh iGPU HDMI Audio Guide

These steps will work with the latest graphic cards available from Nvidia including Pasca l(GTX 10XX) , however some  pascal based graphics cards will require an additional step compared to maxwell. I can confirm that HDMI + Display Port audio work both on an EVGA GTX 1050 Ti and an EVGA GTX 1070 FTW2 with this guide. Also using the steps in this guide allowed me get HDMI + DP audio working on my Gigabyte AMD RX 560 4GB which are supported macOS 10.12.6 or later.




 Hackintosh HDMI Audio + DisplayPort Audio

Step 1: Mount the EFI Partition

  1. Open Clover Configurator
  2. Select Mount EFI under TOOLS
  3. Click Mount Partition for [Current Boot Disk]
  4. Click Open Partition 

Step 2: SSDT

This small step will get most graphics cards working HDMI + DP sound.

  1. Download SSDT-HDMI-NVIDIA-PEG0.aml
  2. Double Click it to unzip
  3. Navigate through your mounted partition to EFI/CLOVER/ACPI/patched/
  4. Paste SSDT-HDMI-NVIDIA-PEG0.aml in that location

Step 3: Kext Support

Some cards will require an additional kext to get audio working.

  1. Download HDMIAudio.kext and unzip it
  2. Navigate through your mounted partition to EFI/CLOVER/kexts/Other/
  3. Paste HDMIAudio.kext here

Step 4: Restart

  1. Restart and you should have audio thru HDMI or Display Port
  2. For reference your EFI should have the files in exact locations shown in the image below:
HDMI + DP EFI Folder Example

HDMI + DP EFI Folder Example

Audio Notes

Some Pascal graphic cards may still not work after following this guide. If your graphics card has more than one display port try plugging in your cable to different ports as some users reported that some of the ports work while others don’t.




Leave a Reply

56 Comments on "Hackintosh HDMI Audio + DisplayPort GFX Card Sound Guide"

Sort by:   newest | oldest
Minh
Guest
Minh

Will this work on my GA-Z270M-D3H with GTX 1050 (non-TI) build?

Charles Richardson
Guest
Charles Richardson

Source of ssdt ? Is this your work ?

panhama
Guest
panhama

not working for me pls help i did everything above:(

Paulo Costa
Guest
Paulo Costa

Gigabyte Z270M-D3H + Gigabyte 1050 TI OC and didn’t work 🙁

Paulo Costa
Guest
Paulo Costa

Solved, but I have to install VoodooHDA.kext and AppleHDADisabler.kext on /S/L/E…

Asim
Guest
Asim

I confirm, HDMI sound on my LG 34UC99 with NVIDIA GeForce GTX 1060 6GB works by installing VoodooHDA.

Thanks.

snobrd4life
Guest
snobrd4life

That worked on 10.3.2 with EVGA GTX 1050 2gb. THANK YOU!!!

Lui
Guest
Lui

This dont work for me ;-; GTX 1060 6 GB

Jake S
Guest
Jake S

confirmed working 10.13.4 evga GTX 1070 !!

Julia
Guest
Julia

Gigabyte H270m’M-DS3H + Gigabyte 1050 Ti, doesnt work 🙁

panhama
Guest
panhama

gtx 1070 I did everything above and I have sound output but it doesn’t output any sound 🙁

MrSoundGuy
Guest
MrSoundGuy

Panhama, I have a GTX 1070 as well and the HDMI only works on a certain HDMI port. Have you tried the other HDMI ports?

tuxbrother
Guest
tuxbrother

I am using a evga gtx 1050 TI FTW 4G and the procedure describe here worked for me but audio just on HDMI port. And to make it work I have to connect both cable DisplayPort first, then the HDMI cable to activate my monitor as a sound output

Mariano San Andrea
Guest
Mariano San Andrea

Awesome! Works like a charm. Gigabyte GTX 1060

panhama
Guest
panhama

so I found the solution of my display port sound not working so what I did is I boot it with hdmi cable instead of displayport but I get blank screen which I don’t know why then I switch it to display cable and audio works but I have to do this every single time, do you happen to know why my hdmi port not working? I tried GraphicsEnabler=No and still not working pls help 🙁

Pawel
Guest
Pawel

Hi i have asus 1050 ti and your guide does not work. The device is recognized in the system report, but no audio device 🙁

Anonymous
Guest
Anonymous

Same by me, I also make a DSDT for it, but it don’t work.
Gigabyte GTX 1050ti Windforce OC.
Don’t try it with VoodooHDA, cause I don’t want to have to many different kexts.

Nia
Guest
Nia

Did you ever get this working? Can’t get this to work for Asus 1080 ti.

zebrum
Guest
zebrum

What is HDMIAudio.text? What does it do and where is it from? Sorry not gonna install random code into my kernel with no explanation in the hope of a quick fix, hope you understand.

Anonymous
Guest
Anonymous

Many thanks!
Working straight away with a GTX 1080ti

Yanbo
Guest
Yanbo

Work! But no output control. I can’t control the amplitude of sound…Is that true?

Scott
Guest
Scott

This only works for me upon first reboot. Upon subsequent reboots, the HDMI out option (aka my TV used as a monitor) is no longer found in the ‘Sounds’ output menu. Motherboard sound outputs are still there and work properly. I’m running a GTX 1080 over displayport, and a 7700k on an MSI z170i motherboard on Sierra 10.12.6. Any ideas on how to get it to persist?

Guest
Sakis Glaveris

can i try this quide for make sound to my card?

Gigabyte Geforce GTX 1050 2GB GV-N1050WF2OC-2GD Windforce

https://www.amazon.co.uk/dp/B01MF8R2NR/ref=as_at?slotNum=190&ie=UTF8&linkCode=g12&imprToken=k0MavSk1Tc58mwBsjGuYvQ&creativeASIN=B01MF8R2NR&tag=tonymacx86-21

Irving Daughters
Guest
Irving Daughters

I am thinking to buy wireless device. I want to hook up my PS3 to my LED TV. Could you recommand me any brand? I’m looking for full HD 1080p video quality. I observe some online review about this, and I think Orei WHD-100 Wireless HDMI may be the best choise. Exactly what do you think?

http://hdmisplitterpro.com/

Jackqueline Nay
Guest
Jackqueline Nay

I am thinking to get HDMI device. I want to connect my PS3 to my LED TV. Could you recommand me any brand? I’m looking for full HD 1080 p video quality. I see some online review about it, and I think Nyrius ARIES Pro would be the best selection. What do you think?

bestproducts-4u.com/best-wireless-hdmi/

Anthony
Guest
Anthony

works!
Is there any way to control the volume from software?

Lucas
Guest
Lucas

didn’t work for me. I’m using gtx 1080 FE hdmi port.

MEMO
Guest
MEMO

it works fine with NVIDIA GeForce GTX 660 thanx a lot

SeriusNtentions
Guest
SeriusNtentions

Hackintosher do you have a guide which resolves Ultra-wide monitor flickering? I have searched the internet going in circles on this subject. I just bought an LG 29UM59-P. I have spent hours trying to make it work on my M270X board with MSI GTX 970. DVI port works fine. I am still on 10.13.2 with Nvidia Web Driver 378.10.10.10,25.103

Thank you!

ZinkDifferent
Guest
ZinkDifferent

You need to use a DisplayPort or Mini DisplayPort cable.

SeriusNtentions
Guest
SeriusNtentions

Hackintosher do you have a guide which resolves Ultra-wide monitor flickering? I have searched the internet going in circles on this subject. I just bought an LG 29UM59-P. I have spent hours trying to make it work on my M270X board with MSI GTX 970. DVI port works fine. I am still on 10.13.2 with Nvidia Web Driver 378.10.10.10,25.103

Thank you!

previous post had the iron email.

Infy
Guest
Infy

on the menu of your LG go to Settings > Displayport 1.2 = disable. fixed for me with gtx980. If you’re using HDMI, try that with displayport instead.

monsterz
Guest
monsterz

Hello hackintosher! I’ve followed all the above steps correctly but still can’t seem to get the audio through my HDMI display. The only way I was able to was the VooDoo HDA kext but that made the audio crackle and sound terrible so I uninstalled it. I’m running a Vanilla Appla HDA kext currently in my S/L/E folder. I’m running a Gigabyte GeForce GTX 1050 WindForce. Any help would be greatly appreciated. Been searching for a solution for a while now.

Guest
His_Turdness

Used to work on my old installation. I think I was using the WEB driver (xx.103) from 10.13.2. Doesn’t work now that I’m using the latest WEB driver, which works pretty well otherwise.

His_Turdness
Guest
His_Turdness

I feel dumb. This didn’t work because I had checked Inject Nvidia in CloverConfigurator under Devices. I was looking at my About this Mac and wondering why my VRAM shows only 256mb. All fixed now and everything working.

mathn
Guest
mathn

It didn’t work for me either until…

I downloaded VoodooHDA.kext, pasted it in the /Volumes/EFI/EFI/CLOVER/kexts/Other-folder.
Rebooted my system.. and it all worked!

Link to VoodooHDA: https://sourceforge.net/projects/voodoohda/

montan
Guest
montan

Same for me. After installing voodoohda it works. 4k60fps over hdmi with sound with a gigabyte NV 1030 2GB

sdwfg
Guest
sdwfg

working for both hdmi and display port, 1080Ti

sdwfg
Guest
sdwfg

Does SSDT-HDMI-NVIDIA-PEG0.aml disable igpu? I am trying to make both ogpu and peg’ hdmi working? I have 8700k with voodoo driver installed. Thanks.

dkjackson
Guest
dkjackson

I just followed this guide and it worked fine for my build.

His_Turdness
Guest
His_Turdness

Doesn’t work anymore on 10.13.4

fred24111
Guest
fred24111

Just to confirm this worked with 10.13.6 on my Sapphire Nitro+ RX 580 8GB to get working hdmi sound on my TV. Thanks Hackintosher!!

Douglas
Guest
Douglas

did not work for my gtx980

Guest
Hugues Gaudreault

why is it that you only have 2 kexts in the other folder