Hackintosh High Sierra 10.13.4 Update Guide

The High Sierra 10.13.4 update is the fourth major release for macOS High Sierra. Added to macOS is a number of undocumented fixes, improvements, security enhancements to macOS as well as support for eGPU’s. This new external graphic card support expands the cards that are natively compatible with macOS and even extends support for even older AMD GPU’s. One Hackintosher reported that he was finally able to get acceleration with an AMD XFX R9 Fury Triple GPU in 10.13.4. If you were holding out on an AMD graphics card now is the time to get one.

Apple’s Recommended Graphics Card List:

eGPU Info: https://support.apple.com/en-us/HT208544

Download High Sierra 10.13.4

High Sierra 10.13.4 can be downloaded from the App Store. 10.13.4 or on Apple.com’s support page.  If you would like to download a full version of 10.13.4 instead using the update tab in the App Store you will need to first delete Install macOS High Sierra from Applications folder if it exists. Here’s the links:

10.13.4 Update Quick Notes:

Hackintosh 10.13.4 Install Overview

This update is not automatic, when the computer reboots after installing in the app store you will have to select: Install macOS from “drive_name” to complete the update in Clover EFI Bootloader. I actually had to select Install macOS From… twice in Clover EFI Bootloader as the first time it rebooted before completion, while the second time it finished the install. There may be up to 4 restarts to finish the update. For Ryzen users a fresh install of 10.13.4 is required as the update feature does not work for non-Intel processors. If you end of getting the macOS cannot be installed error. See the updated [Guide] macOS could not be installed

Hackintosh Nvidia 10.13.4 Web Drivers

Nvidia Web Drivers have been for 10.13.4 and available for install, however they still suffer from the same lag issues as they did in 10.13.3, but there is a version of NvidiaGraphicsFixup.kext with a fix.

Update: I’m having issues with Safari and the latest Web Drivers where a black screen appears over the upper half of the browser. Other hackintosher’s are also have issues with certain web apps and Preview.

If for whatever reason you experience these issues or have troubl installing the Web Driver you can use an alternative method to install a previous version of the web driver that may work better and change the build version to 10.13.4’s 17E199

https://hackintosher.com/forums/thread/how-to-install-nvidia-web-drivers-with-webdriver-sh-on-a-hackintosh.48/

There are now two Web Driver versions available from Nvidia. The latest one fixes lag and some other issues.

Lastest Web Driver for 10.13.4:

The previous Web Driver released for 10.13.4 387.10.10.10.30.103 (17E199) is problematic causing issues with Safari and lag across macOS requiring a patched version of NvidiaGraphicsFixup placed in /Volumes/EFI/EFI/Clover/kexts/Other of the mounted EFI partition to reduce lag.

If you have trouble installing either Web Driver try installing the Web Driver through a script or consider using the Web Driver from 10.13.2 if you experience an issues.

Update Kexts for 10.13.4:

I recommend updating all your kexts especially Lilu.kext to the latest version:

Apple File System Users

Those already using an HFS+ drive don’t need to worry about theirs being converted to APFS on update.

if you have an APFS formatted drive, make sure you are using the latest version of apfs.efi unzip the download below and stick it in EFI/Clover/Drivers64UEFI/

Hackintosh 10.13.4 USB Patch

High Sierra 10.13.4 requires a new USB patch to get all USB/USB3 ports recognized and working.

  1. Mount EFI Partition with Clover Configurator
  2. Navigate to /Volumes/EFI/EFI/Clover/
  3. Right-click open config.plist with Clover Configurator
  4. Click Kernel and Kext Patches under SECTIONS of Clover Configurator
  5. Click the “+” button near the bottom to add this patch:
    • Name*: com.apple.driver.usb.AppleUSBXHCI
    • Find* [HEX]: 837d940f 0f839704 0000
    • Replace* [HEX]: 837d940f 90909090 9090
    • Comment: USB 10.13.4+ by PMHeart
    • MatchOS: 10.13.x
  6. Save config.plist

10.13.4 Hackintosh USB Patch config.plist Clover Configurator
Note:

If you are updating from a version of macOS earlier than High Sierra 10.13.0 follow one of these guides before updating to 10.13.4:

Leave a Reply

88 Comments on "Hackintosh High Sierra 10.13.4 Update Guide"

Sort by:   newest | oldest
hasheemweb
Guest
hasheemweb

How can i apply the patch for my usb3 ? Thanks

patricia2626
Guest
patricia2626

can we get video of this it be easier to follow

patricia2626
Guest
patricia2626

can we do fresh install of macos high sierra for intel

David
Guest
David

Does the new usb patch replace the old one or do we have to use both of them ? Thanxxx

Navjot Singh
Guest
Navjot Singh

I did all of this, but instead of showing “Install macOS” it is saying “Reinstall macOS”.

And it asks to connect to internet, i don’t want to install through internet.

What to do?

Holden
Guest
Holden

I’m having this same issue. Did you have any luck?

Guest
Scott Turvey

Just a heads-up; some display adapters/utilities are being rendered inoperable by 10.13.4 upgrade.

Examples:
* adapter – ASUS-MB169 Ezlink display (https://www.displaylink.org/forum/showthread.php?t=66046)
* Adapters – Products using DisplayLink hardware (https://support.displaylink.com/knowledgebase/articles/1849327-important-information-on-macos-10-13-4-update)
* utilties – Mac Desktop Extension Software Duet Display (https://forums.macrumors.com/threads/mac-desktop-extension-software-duet-display-rendered-inoperable-in-macos-10-13-4-updated.2112589/page-2#post-25940631)

I already had rto revert to 10.13.3 because of this…

Chris
Guest
Chris

Thanks again, this guide helped greatly!
The update unfortunately broke the Hardware encoding and HEVC support. Previously I had the internal Intel Graphics and my AMD GX 560 listed. Now it is only the AMD? Do we need to adjust the settings. I used your guide How To Fix Videos Rendering issues. Thanks heaps!

jptwist
Guest
jptwist

Are you injecting Intel headless (0x1912001) or otherwise?

Asim
Guest
Asim

Thank you ! I followed the instructions to update and they worked great !

patricia2626
Guest
patricia2626

can amd 560 work too in the Apple’s Recommended Graphics Card List

Robert Bohannon
Guest
Robert Bohannon

Apple isn’t going to recommend the RX 560 for an eGPU. Who’s going to spend all of that money on the enclosure and then put a cheap and underpowered GPU in it?

But maybe you misunderstood what the recommendations were for? (You could have clicked Apple’s link below them…)

kicsiii
Guest
kicsiii

Thank you! Working great!

Frank
Guest
Frank

Hi..Thanks to your guides i’m in the process of building my first Hackintosh. So with 10.13.4 are the new AMD gpus natively supported and easier to install? Would you recommend them over Nvidia cards? Planning to use the machine for video editing (premiere pro etc).

I’m planning to go with the Vega 64 for AMD or GTX 1070 for nvidia.

Guest
Vardaan

Hi!
After 10.13.4, I’m having trouble with the integrated graphics, Onboard Audio, and USB Drivers… Can you please help with the same… Also, my DELL bluetooth keyboard and mouse seem to lag sometimes, then I have to re-insert the adapter to fix it for a while… could be a driver issue..

Here are my Hackintosh’s specs:

Intel i7 8700K
Aorus Gaming 5

David Noreña
Guest
David Noreña

@Hackintosher thanks for all your posts, can you please add one explaining how to make a clean install of 10.13.4, I’m using Unibeast 8.2 and It has a lot of problems, clover boot, doesn’t show the option to install.

His_Turdness
Guest
His_Turdness

I recommend to not use UniBeast, or any tonycrap software. They cause a lot of issues.

David Noreña
Guest
David Noreña

Yeah I have read a lot about that, then how can I make my usb bootable ? Please help, I will try with the createinstallmedia command and the clover efi boo loader 4411, but I don’t know how many options do I have to choose in clover installer, I know how to copy to efi the apfs.efi file … Do I need something else ?

His_Turdness
Guest
His_Turdness

Depends on your motherboard. If you got UEFI BIOS, you should pick UEFI only and that’s pretty much it. Then follow the general guide on this forum.

David Noreña
Guest
David Noreña

I have and ASUS B250 PRO WITH A GTX 1050i and Intel 7700k I have followed all steps but again, the colver bootloader doesnt show me the usb install option

Robert Bohannon
Guest
Robert Bohannon

Update Clover to the newest version, that has 10.13.4 support. This isn’t difficult.

David Noreña
Guest
David Noreña

Yeah , I forgot to update, it was a clover, finally a couple of days ago, I have 10.13.4 ! 🙂 Thank you !

MJNiazi84
Guest
MJNiazi84

Hey Hackintosher I have been using your UEFI folder for 10.13.3 it worked like charm
but way of my installation is different I have a vmware image of 10.13.3 and through that I have assign my ssd as secondary HDD and Install directly onto that then through diskpart I mounted my efi Partition and with the help of explorer++ I just copied yours EFI folder everything worked great now I am doing the same with 10.13.4. I hope for success. Let you know soon

Guest
gernot

Thanks a lot! everything went smoothly..
I’ve learned to wait for your guides to update.. for a reason 😊

Sakthivel
Guest
Sakthivel

Asus z270 E strix gaming motherboard how to patch WiFi and Bluetooth driver update

rvs.satyaditya
Guest
rvs.satyaditya

i’m not able to install every time i install on reboot the bios prompts MAC OS X boot failed and after that on reboot it says some updates were not installed as it pops from notification center.
please help!!!

pafofi
Guest
pafofi

Well… I did exactly what is written on your website (it worked perfectly with your “fresh start guide”) but here it just broke my OS… I’m not able to boot anymore and I don’t have a clue about what went wrong… I’ll try to re-install over 10.13.3 as I did the first time, hoping it will save my data (I did no back up, of course… typically me !)
Anyway thanks for your amazing website with so much help and detailed procedures !

ARZACH
Guest
ARZACH

First time hackintosher. Great site. I downloaded the installer from the Apple Store and it’s showing as 10.13.4. For a clean install do I follow the instructions for 10.13.3 and just do the patches indicated here? Can I do the patches on the USB before installing?

patricia2626
Guest
patricia2626

can we get list for 560 models too in your list Apple’s Recommended Graphics Card List:

Robert Bohannon
Guest
Robert Bohannon

Why the duplicate post, asking the same thing?

Stas
Guest
Stas

usb3.0 works!

Guest
Michael Jones

Followed this guide and boot to a black screen with my Asus RX 580 8GB. Extremely frustrated at this point. I’m stuck. Using the latest Lilu + Whatevergreen

Rodrigo
Guest
Rodrigo

I’ve succesfully updated, but graphics are glitchy, i have updated all the kexts and HD630 is working “fine”.
Screen rendering is all distorted and Frozen.
My componente are:
Asus Strix B250F and an intel I7 7700.
Audio and HEVC are fine, it’s just the screen that fails!
Anyone with the same problem?

Matteo
Guest
Matteo

same problem with me.. any help?

Guest
Rodrigo

Yes! I changed SMBIOS from iMac 18,3 to iMacPro 1,1
as for the IntelGFX FakeID: 0x59168086
Just tried with 0x3E918086 and 0x3E928086 and both gave me 7mb on graphics (those ids shouldn’t work anyways with KabyLake)
What works: iGPU, HEVC encode/decode, iTunes and iPhone syncing.

Ruben
Guest
Ruben

same problem

Quad3000
Guest
Quad3000

I’m getting some serious flicker issues with my i5 Coffee Lake iGPU… 🙁
I can’t find a solution… I’m re-installing 10.13.3 on my Hackintosh “mini”.

Everything else worked though.

Matteo
Guest
Matteo

Using smbios 18,1 Or imacpro 1,1 seems to resolve the issue

Quad3000
Guest
Quad3000

Thanks for the tip. I’m trying it one more time.

Guest
Rodrigo

Do you know if that works for a Kaby Lake cpu?

Matteo
Guest
Matteo

don’t know about that sorry

Quad3000
Guest
Quad3000

Changing the smbios to 18,1 worked! And solved flickering issues when changing resolution on 10.13.3 as well (not relevant anymore). Using a Gigabyte Z370N WIFI + i5-8400.

Thanks for the info Matteo!! 🙂

Guest
Guido

I had flickering with 18,1/18,2/18,3. However ist stopped, when I changed it to 14,2.

i5 8400 / Aorus Z370 Ultra Gaming/ Intel HD 630

Tank84
Guest
Tank84

im scared 🙂

Benjamin
Guest
Benjamin

Hello,

Thanks for your guides, you’ve helped me many times so far and appreciate you share knowledge to this community. I was trying to upgrade to High Sierra making fresh install, and after I select “Install macOS High Sierra” option in Clover and It’s loaded everything with Apple logo, suddenly I got message on my monitor saying “NO VGA SIGNAL”. So, is it actually possible I can’t install it without DVI or HDMI? Yes, I’m using VGA, actually VGA-to-DVI adapter since my monitor is pretty old and I know it’s pretty luck to have working 10.12.6 on VGA but was just wondering this. Do I need new monitor or is there workaround? Regards.

Jorge Ramos
Guest
Jorge Ramos

Guys, I did the update to 10.13.4 from 10.13.3 via AppStore but now my Hackintosh won’t boot.

The error in Verbose mode is “[IGPU] Hash data from ME never returned, status = 1, doing retry #” and keeps doing this til it reboots at around retry number 50.

If I use -disablegfxfirmware then it boots but Internal UHD 630 is so messed up, so glitchy.

Does anyone know how to fix this? I can send pics of my config. and Kexts.

Also, my build is this one.

Gigabyte z370 XP SLI (BIOS F4)
Intel i7-8700 3.2Ghz (6-cores)
32GB Ram DDR4 2400MHz
Wifi+Bluetooth Apple Broadcom
Samsung SSD 256Gb 840 EVO

Guest
phuc

why my vga card MSI GTX 750 ti not working HDMI port black green just out DVI port ok

ccphuc
Guest
ccphuc

why my vga card msi gtx 750 ti hdmi port not working just dvi port work ok

may pc : H110m-s2pv + cpu core i3 6100 + ddram 4 bus 2133

Apple Hunter
Guest
Apple Hunter

UPDATED SMOOTH WITHOUT A ISSUES. ADDED AppleUSBXHCI PATCH THEN DISABLED OLD PATCH BUT NOTHING SPECIAL.

Guest
Alan

I have tried updating but i get an error;

iMac opendirectoryd[186]: [auth] failed to write file

i cannot get this to update properly.

Joao
Guest
Joao

hello. I think I encountered a bug that make me lost 1 day =D

When you set automatic login for your user, the Nvidia driver raises a boot loop and won’t open (Only with nv_disable=1 works)

The boot error Is like:
ACM: delete credential set (…)

Pauloleco
Guest
Pauloleco

Same here realy strange…

nitin
Guest
nitin

Ok i followed your guide and build myself a hackintosh and followed your other guides to update high sierra to 10.13.3. I am on iGPU no grpahics card yet as prices are very high. Have 8700k and gaming 7 MoBo.

When i try to update to 10.13.4 i start having graphics issues. I updated my kexts and applied usb patch but the graphics issue dosen’t go. In Smbios I have selected iMac 18,3 .

nitin
Guest
nitin

Figured this with iGPU only till iMac 18,1 profile works. Now everything is working smoothly

irhako
Guest
irhako

Hello everybody. I got my Gateway NV59c fully working on High Sierra, but after 10.13.4 update I got black screen, I only can see trough screen sharing on my iMac, but I can fix to normal again… Everything works like a charm, except from this black screen and some sort of heating… any ideas???
My specs. are:
Gateway NV59C 2.13 Mhz Intel Core i3-330M
Intel HD Graphics Arrandale (8086:0040) 15″ 1366×768 Full QE/CI (before update)
320 GB HDD | 8 GB Memory
WiFi Atheros | Intel High Definition Audio HDMI | No Ethernet
macOS High Sierra 10.13.4

Thank you all!!!

Ruben
Guest
Ruben

after update i have problems with graphics. in “About this Mac” written 1500mb graphic card, but i cant work with this. proc: i7-7700, motherboard: asus h110m-k

chud
Guest
chud

Man you are the best! All my usb 3.0 ports work like a charm. 🙂

mjniazi
Guest
mjniazi

Hi Hackintosher I have done it. Installed High Sierra 10.13.4 with HFS+J partition and your UEFI Folder with all the updated kext and kaboom. my specs are i5 8600K Radeon RX 570 16gigs of RAM and MSI Gaming Carbon Z370 AC. Thanks a lot with all the best wishes to you and your work

MacCharlie
Guest
MacCharlie

Hi, many thanks for all your great work Hackintosher. I updated to 10.13.4 and have problems USB patch as it only works on USB 2.0. and not on USB 3.0 or 3.1 I updated the all the Kext files to the latest release Kext files. I also updated my config.plist in clover configurator classic 4.61.0.0; see my dropbox link: https://www.dropbox.com/sh/7ehf1k9paat29ya/AAA7UWXjUJeTTh-Sqlb8kaUJa?dl=0
I’m running the same configuration as GIGABYTE Z370 AORUS GAMING 7 HACKINTOSH BUILD GUIDE without the overclocking on CPU and Different Ram and case. I7;8700K, Dark Rock Pro 3, Gigabyte Z370, Gigabyte AMD Radeon RX 560 Gaming OC 4G , SAMSUNG 960 EVO NVME SSD,
32GB Corsair Vengeance Red DDR4 Desktop RAM 2400MHz Memory (2x16GB) PC4-19200. I been stuck all day and can’t get it to work. Any suggestions would be much appreciated as everything else seem to work. Thanks

3alech
Guest
3alech

Are there any known issues with Security Update 2018-001?

infra
Guest
infra

Confirmed to work on my Coffee Lake 8700K build using an ASRock Z370 Extreme4. Build photos: https://imgur.com/a/GwMrKkG

Guest
Giles Westwood

Heya infra, do you have your efi to share? I’m not having a great result with this motherboard. I’ve upated to the 1.8 bios but when it wakes up from sleep I get all my usb drives disconnected, this is even before he update.

Ludus
Guest
Ludus

I can say, all issues with the earlier versions with the GTX1060 are gone. No lags, no black screen, newest NVidia Driver. Rapid damn fast.

I think Apple and NVidia has changed a lot, and so the System is stable now again.

Also I’ve installed these files in the “Others” folder of the clover kext folder:

FakeSMC.kext (11.11.2017)
Lilu.kext (27.01.2018)
NvidiaGraphicsFixup.kext (08.01.2018)
RealtekRTL8111.kext (11.11.2017)

That are all the files I’ve added. Nothing else, because I’m using a PCI USB Card, PCI Ethernet Card and an USB Sound Card.

Michael
Guest
Michael

Hi, i use your guide 10.13.4 USB Patch but my usb 3 is not working….

Guest
Giles Westwood

I tried the install on my ASROCK Z370 Extreme4 system with amd card and I’m left with a blank screen after a couple of reboots. I’ve enabled verbose on boot but nothing obvious shows as an error. Is the bootup log stored anywhere so I can see it? I’ve enabled the intel onboard and the amd card in the bios to get improved performance in final cut but other than that it’s like the guides. No apfs either.

His_Turdness
Guest
His_Turdness

My computer autoupdated. Had to run graphics script to get WEB drivers again. Didn’t update APFS EFI or Lilu. Everything seems to be working just fine.

Guest
Giles Westwood

phew His_turdness I wish it was that straightforward for me. I wonder if I should just leave everything as is. I’ve think I’ve managed to get a boot log to always be written to /boot but it’s a binary file so I can’t view it when I boot up on another working partition.

Guest
Giles Westwood

Okay got the upgrade to work. I went back to the standard EFI without all the changes in :-

https://hackintosher.com/guides/fix-rendering-issues-fcpx-high-sierra/

Carlos
Guest
Carlos

Hello, Thanks for these guides! I am completely lost now. I’ve been trying for a week now to get a fresh install 10.13.4
Now I’m stuck getting the

kextd stall ‘AppleACPICPU’

I’ve updated the FakeSMC, don’t know how to do the NvidiaGrapicFixUp
updated APFS.EFI with 10.13.4, updated Lilu. Did the USB3.0 Fix thing as well. Redownloaded HSierra multiple times nd rebuilt the install drive multiple times.

Using a Samsung EVO 860 as my Install stick.

Specs:
GIGABYTE-Z370-AORUS Game 7
Intel 8700K
Ballistix 16GB 2400Mhz
Gigabyte GeForce GTX 1050ti
Samsung EVO 960

*Any help is appreciated. This build is intended for a Music Recording Studio using Pro Tools with usb Antelope Audio Converters. I will also do Video Editing and Coloring in Premiere and Davinci Resolve. If this helps with context.

Carlos
Guest
Carlos

…help???

kuaytee
Guest
kuaytee

Hi, I have follow every single steps, but I’m unable to update to 10.3.4 when I did a fresh install. I’m using RX2700x and rx580. Is there anyway to update?

mythamp
Guest
mythamp

@Hackintosher

Can you update this guide for AMD RX580 users. They can now remove Shiki, Lilu and Whatevergreen kexts and instead just add “HDMIAudio.kext” for audio output from DP or HDMI.

Host_free
Guest
Host_free

[IGPU] Hash data from ME never returned, status = 1, doing retry #