Hackintosh High Sierra 10.13.6 Update Guide

The High Sierra 10.13.6 update is the sixth major update for macOS High Sierra.  This update adds AirPlay 2 multi-room audio support for iTunes and iTunes 12.8. Other than that this is a very minor update with a number of undocumented fixes, improvements, security enhancements to macOS. This is a minor update and the last one until Mojave comes out this Fall. Since it’s a very minor update with many only bug fixes no changes should be needed to be made to the EFI of your hackintosh.

Download High Sierra 10.13.6 (Build 17G65)

High Sierra 10.13.6 can be downloaded from the App Store or updated from an earlier version on the update page. 10.13.6 or on Apple.com’s support page.  If you would like to download a full version of 10.13.6 instead using the update tab in the App Store you will need to first delete Install macOS High Sierra from Applications folder if it exists. Here’s the links:

10.13.5 Update Quick Notes:

Hackintosh 10.13.6 Install Overview

This update is not automatic, when the computer reboots after installing in the app store you will have to select: Install macOS from “drive_name” to complete the update in Clover EFI Bootloader. I actually had to select Install macOS From… twice in Clover EFI Bootloader as the first time it rebooted before completion, while the second time it finished the install. There may be up to 4 restarts to finish the update. For Ryzen users 10.13.6 should be avoided due to a number of compatibility issues. If you end of getting the macOS cannot be installed error. See the updated [Guide] macOS could not be installed

Warning: Updating to 10.13.6 will cause your drive to be converted over to APFS if it was HFS+ before the update. This wasn’t the case with previous update and is something Apple sneakily put in place in a more aggressive approach to getting people to use the Apple File System or APFS. AS of now HFS can be used on Mojave so for you guys that don’t want your drive converted it may be best to wait until 10.14.

Hackintosh 10.13.6 USB Patch

High Sierra 10.13.6 requires a new USB patch to get all USB/USB3 ports recognized and working. You will also need the USBInjectAll.kext

  1. Mount EFI Partition with Clover Configurator
  2. Navigate to /Volumes/EFI/EFI/Clover/
  3. Right-click open config.plist with Clover Configurator
  4. Click Kernel and Kext Patches under SECTIONS of Clover Configurator
  5. Click the “+” button near the bottom to add this patch:
    • Name*: com.apple.driver.usb.AppleUSBXHCI
    • Find* [HEX]: 837D880F 0F83A704 0000
    • Replace* [HEX]: 837D880F 90909090 9090
    • Comment: USB 10.13.6+ by PMHeart
    • MatchOS: 10.13.x
  6. Save config.plist

Hackintosh High Sierra 10.13.6 USB Patch

Hackintosh Nvidia 10.13.6 Web Drivers

If you have trouble installing either Web Driver try installing the Web Driver through a script or

Update Kexts for 10.13.6:

I recommend updating all your kexts

Apple File System Users

Those already using an HFS+ drive will have their drive converted over to APFS updating to 10.13.6 so it’s a good idea to have apfs.efi or a combination of PartitionDxe-64.efi + ApfsDriverLoader-64.efi in drivers64UEFI folder.

if you have an APFS formatted drive, make sure you are using the latest version of apfs.efi unzip the download below and stick it in EFI/Clover/Drivers64UEFI/

If you are updating from a version of macOS earlier than High Sierra 10.13.0 follow one of these guides before updating to the latest version:

Leave a Reply

50 Comments on "Hackintosh High Sierra 10.13.6 Update Guide"

Sort by:   newest | oldest
andrew_leonard
Guest
andrew_leonard

Have a BCM94352Z card and this update broke my bluetooth. Bluetooth just says “not available” in the menubar. The card itself shows up in the USB section of System Information but there is no information available in the Bluetooth section.

Cubanito
Guest
Cubanito

Update went well, from 10.13.5 with only one restart without the clover menu at the begining and one restart at the end.
Unfortunately HFS+ transferred to APFS. USB not reliable now, sometimes mounts the connected HDD or SSD sometimes doesn’t.

Guest
Miguel

Update broke my drivers iGPU. Since I had to edit KBL driver to support my Coffee lake, I had to edit the KBL kext and KBLbuffer kext and add it to my EFI in order for it to work. If I left in in Mac drive, it wouldn’t load because of a signature issue. Anyhow, I was able to fix it that way…

Guest
kshoe

I’m currently running Sierra 10.12.6. Should update first to 10.13.1 and then to this or can I go straight from my Sierra to this 10.13.6 update? Thanks.

Cubanito
Guest
Cubanito

Thanks!
Do you think is it still better to stay on HFS+? Unfortunately Disk Utility can’t make disk image from APFS. I tried with CCC before your fix, but did not work out. The startup failed at the end on HFS+.

I also had a question on Graphical Acceleration some days ago, could you look into this for me? Using the Intel i7-8700 CPU and the Gigabyte Z370N WIFI ITX motherboard.
One thing is not clear to me:
Do I have to do step 8 with this CPU, to have Graphical Acceleration?
How can I check Hardware Encoding and Intel QuickSync?
This is what I see in the system report:
Chipset Model: Intel UHD Graphics 630
VRAM (Dynamic, Max): 1536 MB
Metal: Supported, feature set macOS GPUFamily1 v3

swarren
Guest
swarren

Do you manually type in the USB fix information, because I don’t see it in the latest Clover Configurator (5.1.3.1) drop down.

swarren
Guest
swarren

Ok, sorry because I am a Hackintosh novice. Do I need to download the update and copy that to the original clover USB that I used to setup the Hackintosh originally? I downloaded via the app store update, clicked reboot but only saw 3 options and none of them were Install macOS from “drive_name”. Sorry, I just got my original Hackintosh built 3 days ago after attempting it almost 1 year ago and putting it to the side.

I was not using the original usb, just the bootloader that I installed so I could boot without the usb installed.

Jonatan
Guest
Jonatan

This update from the appstore (coming from fresh install on 10.13.5) broke my audio again, the rest appear to be working fine… any hints? cause all the changes on the config.plist seem to still be there in the EFI… or maybe there is a new audio patch?

Oscar
Guest
Oscar

Hello, i updated from 10.13.5 to 10.13.6 whith combo update, but now clover configurator don´t mount mi EFI partition. Any solution please? my clover is 4586 version and my clover configurator is 5.1.3.1

Kanhaiya
Guest
Kanhaiya

Please anyone Help Me
i have Radeon HD5870 And HD 6870 GPU but this card not properly work in sierra 10.12.6 & High Sierra GPU give flicking Display problem
Can Share anyone guy best EFI Folder
My Pc Config
MY Pc Config
Gigabyte B85M-D3H
Processor- intel 4460
Ram – 16 GB
smps colormaster 500 watt
GPU – HD5870 And HD 6870

Darin
Guest
Darin

I am also having the same issue. My PC configuration is an i5-6600k, RX 480, Asus Z170-A, and 16GB RAM. Anyone else having a glitch in the graphics?

endrus
Guest
endrus

After updating my system from 10.13.5 to 10.13.6 using the combo Installer the NVMe drive partition was left with HFS+ (macOS journaled). Is it possible?

Also my BT is broken just as for andrew_leonard. Can it be related to NVMe drive?

Guest
Scott Turvey

Interesting. It did not convert my NVmE drive to APFS either. Thankfully. 🙂

Guest
Scott Turvey

Forgot to mention it didn’t mess with my USB ports either. In fact, it just upgraded and came back fine. Everything works (handoff, messages, etc.)

Cubanito
Guest
Cubanito

The full version of the 10.13.6 install app, converted to APFS for me.

François
Guest
François

Hello there, I just tried to update my hackintosh following this guide (I always follow every single of your guides and it always work like a charm…)
But not this time !
My computer is stucked, I don’t know how to make it start again. In clover, I got to boot options, the usual one that should end on 10.13.5 (the one I wanted to update) and one “OS installation” which ends with “files where not found to install macOS”…
Any help ?
Thanks you very much !!

François
Guest
François

Well… I tried booting from Recovery, broken. From TimeMachine, broken. Tried reinstall 10.13.6 from a brand new USB stick properly configured for the occasion… broken. I don’t understand what happened to my hackintosh during this update! Anyway, I had no other solution than format everything and install 10.13.6 from scratch. Doing it right now, seems to go as it should… Will keep posting here for any other poor dudes like me in close future !

François
Guest
François

All right, I eventually had a new macOS installed in 10.13.6… my major trouble now is that I can’t boot as soon as I install Nvidia Web Drivers… the latest or the old ones that worked on previous 10.13.X versions… every time, I’m stuck on next boot and have to go to recovery to open Terminal and delete extensions… Someone would have any idea of how I can manage installing Nvidia Web Drivers on 10.13.6 ? I don’t understand what is not working…

François
Guest
François

[SOLVED]
After massive headaches trying about everything possible to install Nvidia drivers I eventually discovered that the problem was coming from too recent version of Lula or NvidiaGraphicsFixUp kexts ! I had updated to latest just before… I downloaded older versions (4 or 5 version before to be sure) and my computer work perfectly… so I’ll take the time later to identify which kext is causing trouble and from which version it’s not bootable anymore… just to help other people in my case in future… Let you keep posted !

SeriusNtentions
Guest
SeriusNtentions

Merci François! I was having the same issue! I reverted back to Lilu 1.2.3 and my boot loop stopped. The upgrade to 1.2.5 was the culprit for me! Also the APFS (without verbose) which I downloaded from Insanely Mac Forums after my 10.3.5 update works just fine with 10.3.6

Manolo
Guest
Manolo

Actualicé correctamente mi hackintosh de escritorio siguiendo esta guía. Lo que yo hice fue: Primero descargar y copiar en mi partición EFI, en Clover/Kext/Otros todos los kext´s recomendados aca: comparaba las versiones que tenía instaladas vs las descargadas y así las actualicé uno a uno, descargué también el NvidiaWeb, lo quise instalar antes de actualizar, pero me salió un cartel que decía: “esta aplicación requiere 10.13.6″ Así que supuse que debía actualizar y luego instalar, cosa que hice d einmediato, la actulaización. Sin varios reinicios tardó unos 10, 15 o 20 minutos, no tengo en claro porque en pantalla aparecía que tardaría unos 42 min y después se fue reduciendo, total que fue sobre unos 20 min. Al ingresar, tengo la impresión como comentaron algunos, que se quedó y no modificó el sistema de archivos en HFS+, arrancando me decía que NvidiaWeb estaba desactualizado, entonces lo instalé de inmediato, reinicié y walá todo espectacular: mi Hackintosh es una PC armada con Asrock Z97 Pro4, intel Core i5 4460, 16gb a 2400mhz, SSD Sandisk 120Gb, conectado a un monitor Dell 27” HS2717. Espero esto le sirva alguien.

Abz
Guest
Abz

Worked like a charm
Asrock h270 fatal1ty
I5 -6600
Gtx 1070

DmitriZ
Guest
DmitriZ

I did the mistake of updating som kexts before doing the update, and after that it wouldn’t update or even start the old install after that. After forcing it to start from my backup drive (that has different/older versions) I could install… and still it wouldn’t start unless I used the EFI from the backup… Looks like it was Lilu 1.2.5 that was the culprit. Reverted to Lilu 1.2.3 and now it starts again…

dkjackson
Guest
dkjackson

I still have no Bluetooth after upgrading to 10.13.6. I have a duplicate drive with the same kexts, Clover. and config.plist with 10.13.5 and Bluetooth works fine when I boot it. I have moved kexts to other locations as described in the Help Me thread on this problem. Not sure what else to do.

Anthony Andy
Guest
Anthony Andy

Hello, sorry for the English, I do not write it very well ..
I currently have the following components:
CPU: i5 7500
MB: GA-h170
RAM: Kingston 8GB
HDD: 1T Western
GPU: RX 460 2GB

Can I install macOS high sierra without problems?
or am I going to present problems such as sound and internet and black screen?

I appreciate your help.

ESC
Guest
ESC

AUDIO NOT WORKING

GIGABYTE GA-Z270X-UD5 motherboard

Followed your guides last year to get up and running on a fresh 10.13.1 install. Everything was perfect.

I updated to the latest 1.2.5 Lilu.kext to install the 10.13.6 update. The update went smooth but now my audio doesn’t work.

Any suggestions?

ESC
Guest
ESC

I updated the AppleALC.kext to the 1.3.0 version and that fixed my Audio!

Guest
ronnie

Just to pitch in that I had problems with rebooting on loading OSX. Turned out Lilu 1.2.5 (latest atm) was the problem as others mentioned here in the comments. Can now boot using 1.2.4. Seems very strange though…

Also i was slightly unclear on when i was supposed to make clover/kext changes. Is there protocol for this? Thanks again for all the great help and info!

Jeremy
Guest
Jeremy

Any word on if risen cpu users can update?

His_Turdness
Guest
His_Turdness

This is odd. The USB patch restored my previously broken (intel) bluetooth, but busted my USB3.0 SATA Dock. My front panel USB3 isn’t working either. I tried with a USB3.0 Flash Drive. All my USB ports seem to be working in USB2.0 only. Is there a fix for this?

Raphael Huber
Guest
Raphael Huber

Any infos on ultra wide screens working in this one?

citrusjam
Guest
citrusjam

Updated to 10.13.6 before reading this guide. USB 3.0 wasn’t working, found your fix, but my USB 3.0s still aren’t working. Any help would be much appreciated. Thanks.